Important: Please read the Qt Code of Conduct -

Missing variable is: QT_UIC_EXECUTABLE

  • Hello

    I am using QT in a CMake Project. I tried switching to QT5 from QT4 today. My Os is Ubuntu 14.04.01

    When trying to call cmake .. I get the following CMake error:

    CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly.
    Missing variable is:

    qmake --version:
    QMake version 3.0
    Using Qt version 5.2.1 in /usr/lib/x86_64-linux-gnu


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Are you following the Qt 5 cmake guide ?

  • Yes I do, solved the first problem. I use QT with VTK. Not sure where the error was but now after recompilation of VTK with QT I get now the following error:

    in QT 4.8 I used QWebView without problems

    Now I get
    error: ‘QWebView’ does not name a type
    QWebView * qwebview;

    I tried adding WebView as Component but
    find_package (Qt5 REQUIRED COMPONENTS Widgets Core WebView)
    but that was wrong.
    I dont know how to find the name for the proper Module.

  • Lifetime Qt Champion


    Are you using QtWebKit ?

Log in to reply