Plugins for Qt multimedia



  • I am trying to build a plugins for Qt multimedia.
    I found the github below:
    https://github.com/Freescale/gstreamer-imx
    Understand this is for Freescale's imx platform, which make use of imx multimedia capabilities but is this similar to Qt imx platform.

    Below is the the result when i run configure
    root@ubuntu:/home/ubuntu/Music/gstreamer-imx-master# ./waf configure --prefix=PREFIX --kernel-headers=KERNEL-HEADER-PATH
    Setting top to : /home/ubuntu/Music/gstreamer-imx-master
    Setting out to : /home/ubuntu/Music/gstreamer-imx-master/build
    Checking for 'gcc' (c compiler) : /usr/bin/gcc
    Checking for compiler switch -O2 : yes
    Checking for compiler switch -DPIC : yes
    Checking for compiler switch -fPIC : yes
    Checking for compiler switch -std=gnu99 : yes
    Checking for compiler switch -Wall : yes
    Checking for compiler switch -Wextra : yes
    Checking for program objdump : /usr/bin/objdump
    Building for Android : no
    Checking for library dl : yes
    Checking for library m : yes
    Checking for library pthread : yes
    Checking for program pkg-config : /usr/bin/pkg-config
    Checking for 'gstreamer-1.0 >= 1.2.0' : yes
    Checking for 'gstreamer-base-1.0 >= 1.2.0' : yes
    Checking for 'gstreamer-audio-1.0 >= 1.2.0' : yes
    Checking for 'gstreamer-video-1.0 >= 1.2.0' : yes
    checking whether or not the kernel version is greater than 3.5.0 : yes
    Checking for library g2d : not found
    G2D elements will not be built - headers and/or libraries not found
    checking for linux/pxp_device.h : no
    PxP elements will not be built - headers not found
    checking for linux/fb.h and the IPU header linux/ipu.h : no
    IPU elements will not be built - headers not found
    Checking for 'libfslvpuwrap >= 1.0.45' : not found
    The configuration failed
    (complete log in /home/ubuntu/Music/gstreamer-imx-master/build/config.log)
    root@ubuntu:/home/ubuntu/Music/gstreamer-imx-master# ./waf install
    The project was not configured: run "waf configure" first!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.