gmake: *** [project.o] Error 127 while configure qt-everywhere-opensource-src-4.7.0



  • i got this error when i configure the qt-everywhere-opensource-src-4.7.0:
    [root@localhost qt-everywhere-opensource-src-4.7.0]# ./configure
    Which edition of Qt do you want to use ?

    Type 'c' if you want to use the Commercial Edition.
    Type 'o' if you want to use the Open Source Edition.

    o

    This is the Qt for Linux/X11 Open Source Edition.

    You are licensed to use this software under the terms of
    the Lesser GNU General Public License (LGPL) versions 2.1.
    You are also licensed to use this software under the terms of
    the GNU General Public License (GPL) versions 3.

    Type '3' to view the GNU General Public License version 3.
    Type 'L' to view the Lesser GNU General Public License version 2.1.
    Type 'yes' to accept this license offer.
    Type 'no' to decline this license offer.

    Do you accept the terms of either license? yes

    Creating qmake. Please wait...
    g++ -c -o project.o -pipe -DQMAKE_OPENSOURCE_EDITION -I. -Igenerators -Igenerators/unix -Igenerators/win32 -Igenerators/mac -Igenerators/symbian -I/opt/qt-everywhere-opensource-src-4.7.0/include -I/opt/qt-everywhere-opensource-src-4.7.0/include/QtCore -I/opt/qt-everywhere-opensource-src-4.7.0/src/corelib/global -I/opt/qt-everywhere-opensource-src-4.7.0/src/corelib/xml -I/opt/qt-everywhere-opensource-src-4.7.0/tools/shared -DQT_NO_PCRE -DQT_BUILD_QMAKE -DQT_BOOTSTRAPPED -DQT_NO_TEXTCODEC -DQT_NO_UNICODETABLES -DQT_NO_COMPONENT -DQT_NO_STL -DQT_NO_COMPRESS -I/opt/qt-everywhere-opensource-src-4.7.0/mkspecs/linux-g++ -DHAVE_QCONFIG_CPP -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_GEOM_VARIANT project.cpp
    gmake: g++: Command not found
    Makefile:235: recipe for target 'project.o' failed
    gmake: *** [project.o] Error 127
    how can i solve this ?


  • Lifetime Qt Champion

    Hi,

    You need to install g++

    On a side note, Qt 4.7.0 is pretty old, unless you're locked to that version you should at least update to the latest 4.8 or Qt 5



  • thanks for reply.
    i have a device named Friendlyarm tiny6410 with a cd. in its CD ,i have qtopia, qt-everywhere.... , and ....
    but they dont install well on fedora 21 - 32 bit. so i download and install qt-opensource-linux-x86-5.4.1.run. but after install it by wizard and run qt creator. i have an error at first a bout compiler. i dont know how to set the build settings for compiling both desktop and for arm device.
    how can i set that so?


  • Lifetime Qt Champion

    Like I wrote, first thing to do is install g++ from Fedora's package manager


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.