Keyboard Shortcuts do not work in Qt Creator



  • I just started with Qt today. Qt Creator looks great; I am a long-time emacs user but this IDE looks good.

    However, none of the keyboard shortcuts that I expect to work while editing a C++ file seem to work at all. For example, Ctrl+A and Ctrl+E do not go to the beginning/end of lines.

    I am running Linux Mint 17.1, and Qt Creator 3.0.1.

    What am i doing wrong?



  • @jakep

    Hi and welcome! I don't use Qt (yet) under Linux. If you can figure out how to get into preferences then go to environment, keyboard you can setup/reconfigure pretty much as you like!



  • Thanks. That's what I did. I can get to the keyboard setup, and see all of the various shortcuts. They do not seem to work, i.e. they don't have any effect when I try to use a shortcut while editing a C++ file.


  • Moderators

    Is the shortcut you set conflicting with any other (indicated by highlighting in red)?
    For example Ctrl+A is pretty much universally used for "select all" and that's what Qt Creator has set by default. If so you would have to disable that one first.



  • Ah, I see (sort of). I did not set the shortcuts I want to use. They are already listed under text editor in the keyboard shortcut list. But they are indeed shown in red.

    So what does that mean? That is, what does it mean that the shortcut is already present in the keyboard setup, but is in red?


  • Moderators

    When it's red it means more than one action has this shortcut assigned and it will not work.
    Find the action you don't want to use that shortcut and set it to nothing or something else.



  • Oh, thanks a million Chis; that worked. I searched for the shortcuts I want, and the conflicting ones, and set them as needed.

    There are just a few things that are pretty much wired into my brain from years of emacs use. Because I still use emacs heavily for lots of other work I would always be fighting with Creator unless I make a few emacs-y customizations.

    It looks like a really good IDE, BTW. Had I known about it earlier I probably would have switched to it even for C work.

    Best,

    • Jake -

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Since you come from emacs you might also be interested in the FakeVim mode for edition


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.