"Error: register or shift expression expected" when making qt4.7.0



  • Hi, I am currently working with qt 4.5.1 and the arm-gcc 3.4.5 (i can't seems to use an higer version of gcc) and i had no problem with it.
    I wanted to see if i could upgrade my work to qt 4.7.0. I configured it like my old qt source :

    ./configure -embedded arm -no-armfpa -big-endian -qt-gfx-transformed -qt-gfx-linuxfb -nomake demos -nomake examples -no-svg -no-phonon -no-qt3support -no-feature-CURSOR -qt-mouse-tslib -L/usr/local/lib -I/usr/local/include
    

    No problem there but when i "make" it i have the errors :

    text/qfontengine_ft.cpp: In member function `bool QFontEngineFT::init(QFontEngine::FaceId, bool, QFontEngineFT::GlyphFormat)':
    text/qfontengine_ft.cpp:708: warning: converting to `int' from `qreal'
    {standard input}: Assembler messages:
    {standard input}:806: Error: register or shift expression expected -- `orr r3,r2,lsl#16'
    {standard input}:817: Error: register or shift expression expected -- `orr r2,r3,lsl#16'
    {standard input}:7938: Error: register or shift expression expected -- `orr r1,r3,lsl#16'
    {standard input}:7951: Error: register or shift expression expected -- `orr r3,r0,lsl#16'
    make[1]: *** [.obj/release-shared-emb-arm/qfontengine_ft.o] Error 1
    make[1]: Leaving directory `/home/spi/installQt/qt-everywhere-opensource-src-4.7.0/src/gui'
    make: *** [sub-gui-make_default-ordered] Error 2
    

    I am working on a ubutun 14.04 64 bits and my final target is 32 bits.
    I would think the errors are related to this because of the warning: converting to int' fromqreal' but it worked on 4.5.1.
    Any idea why this is happening and how i could solve this ?


  • Moderators

    Have you tried with Qt 4.8.6 (not sure if it will compile using such ancient GCC)? Maybe it is a bug and has already been fixed?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.