Installing Qt Webkit from source



  • I have self-compiled Qt 5.4.1 and installed in /opt/qt-5.4.1.

    However, I encountered an error while trying to 'qmake' my project file:

    Project ERROR: Unknown module(s) in QT: webkitwidgets

    I did sudo apt-get install libqt5webkit5-dev but the error persists.

    I suspect then that apt-get install does not work when Qt-Core was self-compiled. The Qt Webkit source is available on https://qt.gitorious.org/qt The question is, how and where should I install Webkit from source so that it can be detected while running qmake?


  • Lifetime Qt Champion

    HI and welcome to devnet,

    You need to clone the sources of the module then use the qmake of your self-built Qt on it to configure its build. Then the class make + make install.

    Hope it helps


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.