Generic Linux Device and Beaglebone



  • Hello. I encountered a problem. I have Ubuntu 14,04 and Qt 5.4.1 (QtCreator 3.3.2). Also I have Beaglebone. I can connect to Beaglebone via terminal (ssh 192.168.7.2 -l root). But when I do it via QtCreator (Tools->Options->Devices->Add->Generic Linux device) I have got freezed Ubuntu. Mouse and keyboard does not work. In the Generic Linux device I entered the same parameters: IP: 192.168.7.2, login: root, password: not use. I have checked it on Ubuntu 14.04, Ubuntu 14.10, Kubuntu 14.04, Kubuntu 14.10. I got the same freeze system. Also I tried to use several QtCreator (3.0, 3.2, 3.3) This does not solve the problem too.
    I would be grateful for any advice



  • I suggest you to write and verify your program with you machine and than, using a qemu machine or a raspberry pi device, compile it for arm.



  • Unfortunately I can't do it (((. Because I have special cape for receiving radio packets. And I need to monitor it in real time



  • What operating system are you running on the Beaglebone? How did you install Qt Creator? Can you try to reinstall it or try to install it from a different package (bundled with Qt or standalone)?

    I've never seen a lockup from Qt Creator when trying to connect to a Beaglebone.



  • Hi Pavlya, did you manage to get this working? I have the same problem.
    I'm using Beaglebone Black running Debian and have Ubuntu 14.04 on my desktop with QT 5.4.1 (x64)(Creator 3.3.1)
    I can connect from my Desktop using PUTTY or terminal without any problems.
    BUT I have problems from QT, when I try to Add a kit (Generic Linux Device) it locks when press OK to accept the IP Address and Username etc.

    This is when it tests the connection to the device.

    I have reinstalled, I have also tried from another laptop with the same Ubuntu and have the same problems.

    Any help appreciated.
    Thanks


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.