[solved] Installer certificate problem



  • Hello,
    need some help to install Qt from installer, please.
    I do not know how to handle/ repair/ fix this problem.

    ./qt-opensource-linux-x64-1.6.0-8-online.run
    Warning: QString::arg: Argument missing: SSL error: %s, The issuer certificate of a locally looked up certificate could not be found

    Warning: QString::arg: Argument missing: SSL error: %s, The root CA certificate is not trusted for this purpose



  • Hi,

    seems only a Warning.
    Is the Installer failing??



  • The setupwindow of the installer shows a a red message:

    Network error while downloading target: '/tmp/qt_temp.XM5660'.
    Error: SSL handshake failed:

    now the quit option is the only possible.



  • mmmm,

    some issue contacting the server.
    I just ran the Maintenance Tool (on OS X) and it worked (but was slower than usual).



  • I used the Maintenance Tool for the last weeks without any problem.
    Something changes and i have no idea what changed. So i removed all, downloaded a fresh online-installer and tried to get a fresh qt this way. Unfortunately i do not have any idea on certificates, SSL and similar stuff. Using OpenSuse 13.1 64



  • I have the same problem with online installer. Looks like issue with certificate on server.
    How can I fix this.



  • Hi Sanchir,

    thanks you for this info. I fear we can not do anything in this case and need to wait for attention of the Qt-team. Maybe we should consider to post this problem somewhere else (e.g. in "General and Desktop") , the attention here is rather poor. Anyway, good to know, that it is possible,
    that I did not cause this problem myself, as usual :)
    I also tried to download the offline installer "qt-opensource-linux-x64-5.4.1.run". This ends up with a empty repository list. After adding
    "http://download.qt.io/online/qt5/linux/x64/online_repository/" in MaintenanceTool/ Settings i got the same error "ssl handshake failed"


  • Lifetime Qt Champion

    Hi,

    You can try changing the mirror used with QtSdkRepoChooser

    Hope it helps



  • Hello SGaist

    i tried this already yesterday and it works nice to setup the alternative mirror. But the ssl handshake failure persists :(
    Problem is, i do not even know how this certificate stuff works.
    Do you understand the mechanismn ?



  • hello,

    now it works again, but i do not really know why
    As for OpenSuse 13.1 64, i installed additional packages (2nd and 3rd in the list below). 1st was on system already during the recent errors.

    • ca-certificates - Utilities for system wide CA certificate installation
    • ca-certificates-cacert - CAcert root certificates
    • ca-certificates-mozilla - CA certificates for OpenSSL

    Also used https://github.com/JKSH/QtSdkRepoChooser
    and chose "qtmirror.ics.com". Then added the given path to
    MaintenanceTool / Settings / User defined repositories and
    started update. MaintenanceTool got updated and in a second run also qtcreator. Maybe it's not necessary to use the RepoChooser after installing the ca-certificates-cacert and ca-certificates-mozilla but I'm not sure. Hopel this helps

    Another question: How to logout from this forum and how to enable email notifications on thread replies ?


  • Lifetime Qt Champion

    Click on the profile icon (your avatar) and it's the last entry in the menu.

    For the mail settings, go to your profile then settings



  • SGaist,

    found the mail settings but not the logout (?)



  • Hi,

    click on the button with your avatar and the last entry in the menu is Logout



  • No, there is no "logout" or similar, I'm too stupid or too blind.



  • Hi,

    here Imgur



  • mcosta,

    Yes, found it - not too blind but too stupid :)
    thank you


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.