Qt Creator 3.3.2 + clang + lldb on OS X Yosemite - breakpoints don't work when using "-save-temps"



  • I've been trying to find out why breakpoints don't work for me for a few hours now. It seems that when my .pro file contains QMAKE_CXXFLAGS += -save-temps, the breakpoints no longer work. This seems a bit weird to me - but then again, I have not idea how Qt Creator lldb integration works.

    Details:

    • Qt 5.4.1 from the online installer.
    • Qt Creator 3.3.2 from the online installer. Also tested with 3.4.81 from git today, same result.
    • clang-600.0.57
    • lldb-320.4.160 at /usr/bin/lldb (same result with the lldb under the Xcode directory)

    I'd be interested to hear from someone who knows more about Qt Creator internals - is there any chance that I'm right in saying that -save-temps is the culprit - which it definitely seems to be - and if so, what would be the correct fix? Could this be a bug in Creator?

    I can provide debugger logs if needed.



  • This can be recreated, on my computer at least, by opening any example project in Creator, and putting QMAKE_CXXFLAGS += -save-temps in the .pro file.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You should bring this topic on the Qt Creator maling list You'll find there Qt Creator's developers/maintainers (this forum is more user oriented)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.