MP4 playback disabled by default (Ubuntu-Windows) ?



  • Hello,

    i am playing around with the great new Webengine (my first Qt project). I built a sort of slideshow based on it. It`s really a great component for every modern app and I really like Html5.

    Now my specific question:
    Is MP4/MPEG4 (AAVCS or whatever the codec is called) playback in Qt 5.4 Webengine activated by default or not ?

    I read that Webengine is based on the Chromium project/sources which I guessed can playback all types of media supported in Html5. Does this apply to the QtWebengine also ?

    I cannot get it to run under my LUbuntu environment. Also on my Windows installation I was not able to test it but this was due to that I couldn`t install the webengine component there because of some missing depenencies (VS2013 compiler or so).
    I read some posts that it works under Windows by default, but under Linux not or am I doing something wrong ?

    All other video types (webm/ogg) work perfect for me on Lubuntu using the webengine component.

    I am confused. I could give you some details/sources if needed. Please help !



  • I tried to playback mp4 loading a local html5 file into the QuickFancyBrowser Example. After that I tried to load the jsfiddle noted below into the QuickFancyBrowser example. Playback did not work for both (no build errors).

    My compiler is GCC 64bit.

    Playback with Chrome binary in Lubuntu works fine for both pages (local and jsfiddle).

    Here is the corresponding fiddle: https://jsfiddle.net/tj1e1kpn/

    Any ideas on this? Can I debug it anyway or can i see a log of qt anywhere ? Thank you !!



  • have you figured out any solution? Have the same issue here...



  • Hi,

    As anyone been able to solved this on Ubuntu/Linux? I'm facing the same issue: the HTML5 video tag does not play MP4 videos.

    On Ubuntu the HTML renders and plays MP4 videos in both Firefox and Chromium -- after i installed the ubuntu-restricted-extras package. However, this does nothing for Qt WebEngine. Note, I also tried adding the libffmpegsumo.dll to the plugins/qtwebengine, but that also does nothing.

    I believe the cause may be due to the underlying Chromium browser not building with the necessary h.264/mp4 decoder due to licensing issues. My next attempt was to try to build Chromium with this enabled, which I believe is to set the "proprietary_codecs=1 ffmpeg_branding=Chrome" in the GYP_DEFINES flags. However, I'm not sure where to set this in QT.



  • Hi,
    I am also trying to play mp3/mp4 files from html using QwebEngineview. Can you please tell me how you have worked on this issue?

    Thanks


  • Lifetime Qt Champion

    Hi,

    The enabling of proprietary codec like MP4 is described in the first part of the QtWebEngine Feature documentation.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.