Cannot find -lQtMultimedia



  • Hi guys
    I m trying to record my voice using Qt , but when i run the program i get this error: cannot find -lQtMultimedia .
    How can i solve this issue.

    Thanks in advance



  • What do operation system you use? Version of Qt? And, please, show your .pro file.



  • Qt version :4.7.1 on linux system (ubuntu 10.10)
    this is the .pro file
    @#-------------------------------------------------

    Project created by QtCreator 2011-04-20T10:11:14

    #-------------------------------------------------

    QT += core

    QT -= gui
    QT +=multimedia

    TARGET = audiotest
    CONFIG += console
    CONFIG -= app_bundle

    TEMPLATE = app
    target.path=/usr/local/bin
    INSTALLS=target

    INCLUDEPATH +=/home/aladin/QtSDK/Desktop/Qt/473/gcc/include/QtMultimedia/
    INCLUDEPATH +=/home/aladin/QtSDK/Desktop/Qt/473/gcc/include/
    LIBS +=/home/aladin/QtSDK/QtCreator/lib/qtcreator/libQtMultimedia.so

    SOURCES += main.cpp
    audio.cpp

    HEADERS +=
    audio.h@

    i added this lines :
    1-QT +=multimedia
    2-INCLUDEPATH +=/home/aladin/QtSDK/Desktop/Qt/473/gcc/include/QtMultimedia/
    3-INCLUDEPATH +=/home/aladin/QtSDK/Desktop/Qt/473/gcc/include/
    4-LIBS +=/home/aladin/QtSDK/QtCreator/lib/qtcreator/libQtMultimedia.so

    after i commented line (1) and add .4 for the line (4) but this time i get a new error :
    /home/aladin/Projects/Qt/audiotest-build-desktop/audiotest: error while loading shared libraries: libQtMultimedia.so.4: cannot open shared object file: No such file or directory



  • bq. INCLUDEPATH +=/home/aladin/QtSDK/Desktop/Qt/473/gcc/include/QtMultimedia/
    INCLUDEPATH +=/home/aladin/QtSDK/Desktop/Qt/473/gcc/include/
    LIBS +=/home/aladin/QtSDK/QtCreator/lib/qtcreator/libQtMultimedia.so

    Not needed lines.



  • without line 2 and 3 i m not even to compile the program , and the compiler didn't recognize QAudioInput and QAudioFormat



  • Ubuntu doesn’t have qt-multimedia anymore.



  • Ok remove only this line:
    LIBS +=/home/aladin/QtSDK/QtCreator/lib/qtcreator/libQtMultimedia.so



  • [quote author="Smar" date="1303308632"]Ubuntu doesn’t have qt-multimedia anymore.[/quote]

    so what should i do ? is there a solution to install it in ubuntu 10.10 ?



  • I have no idea why Ubuntu guys did that, but you can use qt-mobility’s qt-multimedia(it is the real multimedia package that will be in Qt 4.8 or so instead of that dummy one that’s in 4.6 and 4.7).



  • I installed the qt-mobility and still get the same error or is there new class to use ?



  • It is most likely in different package; you need to include it with QT += multimedia... Really, read its documentation, the forum is not substitute to doc. http://doc.qt.nokia.com/qtmobility-1.1/index.html



  • I also got crazy with this error, and the documentation really didn't help.
    Combining serveral posts on other forums, and with trial and error, I needed following steps to get the multimedia compiling and running again under Ubuntu.
    (In the .pro file)
    QT += mobility multimediakit
    CONFIG += mobility
    MOBILITY = multimedia
    ... and also remove the QT += multimedia



  • Oops. And also add

    INCLUDEPATH += /usr/include/QtMobility
    INCLUDEPATH += /usr/include/QtMultimediaKit


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.