Qt V5.4.1 and Xcode6.x and OSX versions



  • Is there a way to use Qt V5.4.1 without using XCode6 ? Or use XCode6 without changing or upgrading the OSX version?

    I ask because XCode6 requires Mavericks or Yosemite..and I am currently on Mt Lion (10.8.5) and do not want to change or update the Mac OS version at this time.

    Upgrading to Yosemite will begin an expensive cascade of "upgrades" to other support programs I use.



  • This post is deleted!

  • Lifetime Qt Champion

    Hi,

    If only for OS X, build Qt yourself on 10.8.5 with the latest Xcode available for it. AFAIK it's 5.1.1



  • If only for OS X

    If you mean the target system is OSX..it isn't..it's Android and iOS.

    The Dev system is OSX.

    Basically, I'm getting an error message when compiling the Qt Purchasing/Hangman example project with V541..

    Project WARNING: You need to update Xcode to version 6 or newer to fully support iPhone6/6+
    Project ERROR: Current iphonesimulator SDK version (7.1) is too old. Please upgrade Xcode.


  • Lifetime Qt Champion

    Then you're out of luck, iOS development requires Xcode 6 so Yosemite but you also have the option of using a virtual machine running Yosemite if you don't want to upgrade your main computer.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.