Qmake will not execute INSTALL from .pro file. (Windows 7)



  • I have added a INSTALLS statement to me .pro file to move external DLLs to the build output folder. My app will not run with out them, and I want to avoid copy/paste all the time.

    I have the following:

    @refDLL.path = $${DESTDIR}
    refDLL.files +=
    $${PWD}../imports

    INSTALLS = refDLL@

    In the Build-Step (QT Creator) I have added an additional qmake comment to run install.

    Nothing is executed, and the INSTALL command in the makefile.debug is set to FORCE. FORCE has nothing assigned.

    Any ideas??


  • Lifetime Qt Champion

    Hi,

    Rather than copy these dll's everytime, why not update the PATH environment variable in the run part of the Project panel ?



  • Would using QApplication::addLibraryPath() be an ok solutions? I'll need this anyways for the final deploy/install.


  • Lifetime Qt Champion

    When you'll deploy your application you'll have to copy all the required dlls in the same folder as your application so no need for addLibraryPath.

    However for development it's really time you are losing copying these files. Setting PATH will avoid you to call make install each time.



  • That makes sense. Cheers.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.