Planned maintenance has been done but it did not solve the problem. So work will continue on this and a new time for trying updates will be announced asap.

IMX6 QtWebEngine black surfaces

  • Hello Qt project!

    I successfully built Qt5.4 official release using Yocto sdk for iMX6 Sabre Lite:
    $ ./configure -qreal float -device linux-yocto-g++ -confirm-license -opensource -device-option CROSS_COMPILE=arm-poky-linux-gnueabi- -linuxfb -opengl es2 -prefix /home/kaa/qt5 -no-xcb -no-kms -no-alsa -system-freetype -system-harfbuzz -system-libpng
    And also I have success with building QtWebEngine
    $ cd qtwebengine
    $ /home/kaa/qt5/bin/qmake -r CONFIG+=release
    make -j5
    make install

    I tried to run examples from webenginewidgets folder, I can see browsers controls (navigation panel), but no html rendered surface (black surfaces instead)

    Browsers controls work fine (navigation, url string, page refresh, about window), but I don't see any html content (I tried to open, - but can see only black surfaces).

    ! WebEngine Fancybrowser)!

    Any suggestions? Maybe I forgot some configuration options?

  • Experiencing this exact issue also when using QtWebEngine in Qt 5.4 across multiple ARM platforms. Same problem in both Vivante and PowerVR OpenGLES implementations when used with the EGLFS platform plugin.

    This only occurs in a Widgets application. A Qt Quick application has no such issues for me. Give the example quicknanobrowser a try for example..

  • Thanks for reply!

    I have the same issue with quicknanobrowser from QtWebEngine examples.

  • webenginewidgets is known to be broken on embedded at least. The focus is on the Qt Quick elements for now.

  • Hi agocs,

    Where did you get the information that the webenginewidgets are broken on embedded platforms?

    I'm porting Qt 5.4.1to an embedded platform and I'm seeing the same problem as described in this thread - that quicknanobrowser works, but the webenginewidgets examples bowser and fancybrowser just show black blocks where the web page should be drawn.

    It would be great if you could provide some pointers as to where you got the information about the webenginewidgets being broken.


  • I may have the same issue with QT 4.8.6. I have noticed that text won't be rendered unless there is an image in the paragraph! I have also noticed that background colors won't get rendered. I suggest adding an image to a simple HTML page and seeing if the image gets rendered.

  • There is some additional information on this issue in the JIRA at

  • @oleg_kaa
    I'm facing same issue where quicknanobrowser on embedded linux shows only blank rectangles. I want to debug this issue, I'm newbie in QT. Can you pls guide me to enable logs in qtwebengine/chromium code?. I'm not able to get any logs from chroimum.

  • Could any please mention steps to enable logs in qtwebengine? I am facing same issue for quicknanobrowser. Does QT based browser runs with chromium flags such as --enable-logging --v=1?

  • @ian_009 said in IMX6 QtWebEngine black surfaces:

    A Qt Quick application has no such issues for me. Give the example quicknanobrowser a try for example..
    also meet the same problem, imx6q with Yocto4.9.11 Qt5.8. is some one tried success in a Widgets application?

Log in to reply