Solaris 10 Sparc 64 configure fails



  • I downloaded 5.4.0 on a Sun Blade 2500 64 bit Sparc machine running Solaris 10 Update 11.

    Using the instructions here: http://www.opencsw.org/manual/for-maintainers/buildfarm-setup.html I ran

    ./configure -prefix $MY_PREFIX -opensource -confirm-license -nomake tests \

    -R /opt/csw/lib/64 -R /opt/csw/X11/lib/64 -qt-xcb -platform solaris-g++-64 \    -verbose
    

    and got this error:

    ./configure: test: argument expected

    I submitted that as a bug to bugreports.qt.io (QTBUG-44136) but their only suggestion was to do "bash -x" first. That just gave me a dfifferent error.

    bash -x ./configure -prefix $MY_PREFIX -opensource -confirm-license -nomake tests \

    -R /opt/csw/lib/64 -R /opt/csw/X11/lib/64 -qt-xcb -platform solaris-g++-64 \    -verbose> >
    

    ++ dirname ./configure

    • srcpath=.
      ++ cd .
      ++ /bin/pwd
    • srcpath=/opt/qt-everywhere-opensource-src-5.4.0
    • configure=/opt/qt-everywhere-opensource-src-5.4.0/qtbase/configure
    • '[' '!' -e /opt/qt-everywhere-opensource-src-5.4.0/qtbase/configure ']'
    • mkdir -p qtbase
    • echo '+ cd qtbase'
    • cd qtbase
    • cd qtbase
    • echo '+ /opt/qt-everywhere-opensource-src-5.4.0/qtbase/configure -top-level -prefix' -opensource -confirm-license -nomake tests -R /opt/csw/lib/64 -R /opt/csw/X11/lib/64 -qt-xcb -platform solaris-g++-64 -verbose
    • /opt/qt-everywhere-opensource-src-5.4.0/qtbase/configure -top-level -prefix -opensource -confirm-license -nomake tests -R /opt/csw/lib/64 -R /opt/csw/X11/lib/64 -qt-xcb -platform solaris-g++-64 -verbose
    • exec /opt/qt-everywhere-opensource-src-5.4.0/qtbase/configure -top-level -prefix -opensource -confirm-license -nomake tests -R /opt/csw/lib/64 -R /opt/csw/X11/lib/64 -qt-xcb -platform solaris-g++-64 -verbose
      /opt/qt-everywhere-opensource-src-5.4.0/qtbase/configure: syntax error at line 266: `sdk=$' unexpected

    I have no idea what any of that means or how to fix it. Could some kind soul please help me get Qt installed? Thanks.



  • Someone? Anyone? Could someone at least tell me what "'sdk=$' unexpected" means? Should I change it to sdk=euro, or maybe sdk=CHF?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    I may be the bearer of bad news but you are using there a platform that users of this forum probably don't have access to at all. Maybe solaris for x86 but even so I highly doubt it.

    Anyway, it looks like configure thinks he's doing a configuration for OS X



  • I guess I didn't realize that Solaris 10 was such an orphan. In any case I really could use all the help I can get. It's strange that qtbase/configure wanted to go into macSDify (line 261). I don't have BUILD_ON_MAC set or anything like that. Why is it doing this???


  • Lifetime Qt Champion

    AFAIK Sparc stations where never very common and currently you can only get Sparc servers from Oracle (correct me if I'm wrong). There might be the Solaris 10 x86 images but I'm not sure you can run them on a standard computer/virtual machine (again If you have more infos about that, please share)

    Anyway, it sure is strange. You can call configure with -v to see more in details what happens during the configure process. It might help pinpoint why it thinks he's currently on OS X



  • I don't know why this board fails to post my replies. Anyway, if this goes through, I managed to find a binary package of Qt4 that installed just fine and should serve my needs.


  • Lifetime Qt Champion

    Failure ? Did you had any error message ?

    You might also have posted while your thread was cleaned of spam. Unlucky timing...



  • I don't know - I was getting "unable to process your post at this time", where "this time" ended up being over a whole day. It seems to be working now though.


  • Lifetime Qt Champion

    IIRC, I've seen this when trying to add an answer to a thread in a long opened window. Reloading the thread completely solved that (but you might be experiencing something else)



  • Yes, indeed I like to keep a browser window open all the time and I keep a thread I'm monitoring open continuously in a tab in that window.

    In any case, I'm going to abandon the effort to install Qt5 given that I found a pre-built Solaris 10 Sparc package for Qt4 (at http://bwachter.lart.info/sfw.xp/ if anyone cares). Thanks for reading.



  • This post is deleted!

  • Lifetime Qt Champion

    Nice ! You could try asking the author if he has any plan for Qt 5 :)



  • "Nice ! You could try asking the author if he has any plan for Qt 5 :)"

    Good idea - I just did.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.