I ran qtcreator as sudo and now project isn't working



  • As the title sais, I ran qtcreator once as sudo and everything went fine, until I tried to open qtcreator again. Now all of a sudden I get errors like "Cannot overwrite file [my home dir]/.config/QtProject/qtversion/qtversion.xml: Permission denied". Turns out for some reason qtcreator changed the permissions for all the files in my .config/QtProject/qtversion/ as well as all my source files. Why?

    I changed permissions for these files and now I can open QtCreator once again, but when I try to build my project I get hundreds of strange errors like "undefined reference to QString::fromAscii(char const*, int)" for all Qt functions. What happened and how can I fix this?


  • Lifetime Qt Champion

    Hi,

    Because you called it with sudo, so you ran it with root privileges and thus everything Qt Creator did was with the corresponding rights (writing files etc.). Right now you should delete the build directory and your project.pro.user and open again Qt Creator.

    Important note: never ever do development as root, you can kill your OS without even noticing before it's way too late.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.