[Solved] QNetworkAccessManager: using blocking call and sslv2 issues



  • i have a very simple application:

    @QApplication app(argc, argv);

    QWidget window;
    window.show();

    // perform request
    QNetworkAccessManager m_manager;
    m_manager.get(QNetworkRequest(QUrl("http://somewebsite.com/data.xml")));

    // request callback
    QObject::connect(&m_manager, &QNetworkAccessManager::finished, [](QNetworkReply* reply)
    {
    if(QNetworkReply::NoError != reply->error())
    {
    qDebug() << "QNetworkReply -> Error: " << reply->errorString();
    }
    else
    {
    QByteArray data(reply->readAll());
    qDebug() << data;
    }
    reply->deleteLater();
    });
    return app.exec();@

    it works, the data is printed to the standard output. but before that i get these 3 messages:

    Using blocking call!
    QSslSocket: cannot resolve SSLv2_client_method
    QSslSocket: cannot resolve SSLv2_server_method

    what im more affraid is the "Using blocking call!" message, does this mean the network request is running synchronous? every google search i made about that message only shows a few bug reports as search results. and how can i solve it?

    what about the sslv2 error? am i missing a library or is it something else?

    using linux mint 17 (ubuntu 14.04), i have libssl1.0 and libssl1.0-dev installed.
    thanks in advance.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    AFAIK, it's because the SSL library loaded now is not the same that was used to build Qt. So your distribution has likely remove the support for that version of SSL.



  • thank you so much for the reply.

    "using blocking call!" issue: according to the bug reports i found on google i guess this is a known issue and probably will be solved in future Qt releases so thats nice.

    sslv2 issue: so i guess unless i install the correct libsslv2 version i wont have ssl support? good to know, but my distro only supports libsslv2 1.0 (no 0.98 or 1.3 available in the distro repos).

    anyway, i guess its time i install a new distro with more recent repos (arch linux im looking at you!).

    once again thanks for the help.


  • Lifetime Qt Champion

    SSLv2 and libssl version number is not the same thing. SSLv2 is the protocol version number


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.