[SOLVED] Android Project From 5.3.2 to 5.4



  • Hi,
    i have a current project running on Android 4.2 and 4.4.2 developed with Qt 5.3.2. Now when i build it with Qt5.4 (host lubuntu 14.10 32 bit and OpenSuse 13.2 64 bit; android-ndk-r10c; android-21, android-20, android-19 ) with option "Bundle Qt libraries in Apk" at the start-up:
    i have the same error of "this post ":http://qt-project.org/forums/viewthread/51010/ and in addition at startup some module, randomly, is not found (ex. module "QtGraphicalEffects" is not installed or module "QtMultimedia" is not installed, or module "QtControllers is not installed, ecc.).
    Example:
    qrc:/qml/myqml.qml:2 ((null)): qrc:/qml/myqml.qml:2:1: module "QtGraphicalEffects" is not installed

    Obviously I have a white screen :(. I have unzipped the apk file and in the lib directory i found the Qt libraies.

    Instead if i build with the option: "Deploy local Qt libraries to temporany directory" the app start correctly.
    With this option i can't to sign the apk for the store!

    Any help is appreciated :)
    Thanks



  • Did you clean it and rebuild it completly?



  • Yes, more times.



  • Try to enable verbose output in "Advanced Actions" on Build Settings.

    Search for errors on auto-detect phase of androiddeployqt


  • administrators

    Update the Android NDK to 10d, that might help.



  • With the Android NDK 10d i have the some situation.
    With verbose option for androiddeployqt i have "this":http://pastebin.com/c096Zs9P



  • Strange. qmlimportscanner did not detected QtGraphicsEffect.

    I've made a simple QML file:

    @
    import QtQuick 2.4
    import QtQuick.Window 2.2
    import QtGraphicalEffects 1.0

    Window {
    visible: true
    MainForm {
    anchors.fill: parent
    mouseArea.onClicked: {
    Qt.quit();
    }

    }
    

    }
    @

    You can check "here":http://pastebin.com/zfCYmP3Y the log generated here:

    -- Adding '/tmp2/Qt/5.4/android_armv7/qml/QtGraphicalEffects' as QML dependency

    In you log, there's no reference to QtGraphicalEffect.



  • If i create a new project, i haven't problem. I have only with the my old 5.3.2 project after builded it with 5.4, some module, randomly, is not found.



  • With Qt5.4.x If i unzip the apk is see in the assets/--Added-by-androiddeployqt--/qml/
    only:
    QtQuick.2 !!

    Instead compiling with 5.3.2 i have:
    Enginio Qt QtBluetooth QtGraphicalEffects QtMultimedia QtNfc QtPositioning QtQml QtQuick QtQuick.2 QtSensors QtTest

    I don't uderstand this difference, same project, same manifest, change only Qt version



  • Resolved adding QML_ROOT_PATH = ".." in the .pro of the subdir


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.