Updated to Qt 5.4, still requires my iphone app use iPhoneOS7.1.sdk [SOLVED]



  • So I just installed Qt 5.4 and am having issues with compiling with Xcode 6.1.1. Its complaining with this message:

    @clang: warning: no such sysroot directory: '/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS7.1.sdk'@

    So I copied the 7.1 Sdk into Xcode 6.1.1. It compiles but now, but won't run due to errors with the OpenGL implementation. I'm going to change from using QGLWidget to QOpenGLWidget and see if that works.

    But I thought Qt 5.4 would be fully compatible with Ios 8--which would mean using iPhoneOS8.1.sdk.



  • The problem was, I needed to throw away the android and iphone projects in my main project. Then re-add them with Qt 5.4 and everything fired up fine.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.