[Solved] Cannot compile application for iOS simulator on OS X Yosemite



  • Hi

    I am using Qt5.3 for compiling a Qt/QML application for iOS simulator. At link I get many errors of the type:

    @54 duplicate symbols for architecture i386@

    For example
    @duplicate symbol __ZTS11ModelObject in:
    /Users/n/Qt/5.3/ios/lib/libQt5Declarative_iphonesimulator_debug.a(moc_qdeclarativelistmodel_p_p.o)
    /Users/n/Qt/5.3/ios/lib/libQt5Qml_iphonesimulator_debug.a(moc_qqmllistmodel_p_p.o)@

    I have seen that there are similar error reports on Qt bug tracker, but developers said that the bug cannot be reproduced. I have tried with Qt5.4 RC, but I get the same error.

    Could someone help solving this issue ?

    thanks
    Bogdan



  • Could you post a small project (.pro and source files) that reproduce an error.



  • Hi

    Just removing declarative library from the list of dependences solved my problem:

    -QT += gui declarative qml quick sensors positioning network svg
    +QT += gui qml quick sensors positioning network svg

    thanks
    Bogdan



  • Hi !
    I got the same problem but i need declarative, if i simply remove it i have (of course) a lot of undefined symbols.
    Any Solution for that case ?

    Greetings,

    Nils


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.