Congratulations to our 2022 Qt Champions!

Error when trying to install Qt on Ubuntu Linux

  • Hello

    I downloaded and tried to run it with Ubuntu.

    I typed chmod 700 and then

    I got the message
    line 1: syntax error near unexpected token newline' line 1:<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "">'

    What could be causing this? How do I install qt on Linux?

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Are you sure you didn't just download a webpage ?

  • It turns out that my university blocks Qt. There must be a keyword like free download that causes the University to block it. As a result a web page was downloaded stating that the site was blocked.

    I went elsewhere and downloaded a binary on my laptop and got a message indicating the download was incomplete when I tried running it on the Linux computer.

    I downloaded a newer version of qT and that worked.

    You were right about the web page, thanks

  • Lifetime Qt Champion

    You're welcome !

    Since you could install Qt, please update the thread title prepending [solved] so other forum users may know a solution has been found :)

Log in to reply