No device found



  • Hello, I recently started trying to develope a app for my smartphone. I have made a simple window and tried to deploy it. When I do that i get a pop-up with the message "No device found". I got a samsung gt-i8190 with android version 4.1.2. I have tried both api level 16(4.1) and 15 both with same result.

    The first thing i did was to download sdk,jdk,ndk and ant. After that i set Qt up like this:

    !https://dl.dropboxusercontent.com/u/11985086/Qt-settings.png(Qt-settings)!

    I also tried creating an androidmanifest.xml file looking like this:

    !https://dl.dropboxusercontent.com/u/11985086/androidmanifest.png!

    also with no luck.

    With the sdk manager I tried downloading the google usb driver. I went into Right click my computer->manage->device management->portable devices(the place i could find my phone)-> right click->update driver software->select from computer->..sdk\extras\google\usb_driver

    This just gives me the message(instantly) that windows says the driversoftware is already updated.

    I have tried both in MTP mode and PTP mode on my phones connection type, and usb debugging is enabled, also no luck.

    I tried downloading samsung kies, and this could connect to my phone without any problem(only in MTP mode though)

    I then tried running cmd, went into sdk\platform-tools and running adb devices which listed no devices as attached. I have also tried running adb kill-server and afterwards adb start-server which didn't do anything nether.

    I am running out of options and am hoping you could help me figure out why i can't "find" my device?

    edit1: when I have googled i read multiple places that i should be seeing a device under other devices "android" but I don't after i tried "search after hardware changes"(since the driver software was greyed out i tried this as said just made the "android" device go away?)

    edit2: I just tried to reboot and kill-server and start-server with adb a few times and now i can find my device -> also in Qt. I am still getting an error though when trying to deploy it. gives this error now:

    !https://dl.dropboxusercontent.com/u/11985086/QtError.png!

    Edit3: I took a second look at the compile output and went to the dirrectory "E:/qt/Tools/QtCreator/bin/build-test4-Android_for_armeabi_v7a_GCC_4_9_Qt_5_3_2-Debug/android-build/" but the /bin folder after that doesn't exsist(atleast not what i can see?) any ideas to why this is ?

    Edit4: It is working! Only because a silly mistake by me. I set up my environment variables earlier, but got an error later because i had a space in the directory, so i changed the name - but not the ANT_HOME environment variable! One last question though not really related to my problem, should I delete the thread or keep it open so others maybe can follow my steps(even though its a bit messy lol)?



  • Let it be here, me too faced this long before at the trip start ;)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.