New installation. desktop target not finding compiler.



  • I'm a newbie to this forum. I just installed Qt 5.3.2 yesterday on a Windows 7 machine. The installation had no problems. I started reviewing some of the documentation and then started working through an example program to exercise some of the available options and see the subtleties of the coding methods, etc. I started with the TextFinder example. I went through each step of the tutorial. When I finished, I tried to run the compiler but I was given the following message:

    :-1: error: Qt Creator needs a compiler set up to build. Configure a compiler in the kit options.

    I was trying to target the desktop environment for the application. I tried to find information about setting up the target but I got confused.

    How do I set up my environment for my desktop as the target for the compiled program execution?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you by any chance download a MSVC package ? If so you need to grab Visual Studio from Microsoft's website.

    If you'd rather avoid that, install the MinGW package which comes with the MinGW compiler.



  • Hi SGaist. Thanks for responding.

    That's where I guess I'm confused. I don't have MSVC package installed anymore. I did have the Visual Studio 2013 installed but I uninstalled it. When I completed the installation of the Qt package, there was a mingw482_32 directory under the C:\Qt\Tools directory created, also. This looked to be a completely installed copy of the compiler, but maybe I've misinterpreted that. It does have a bin subdirectory and that includes gcc.exe, g++.exe, etc.

    Do I still need to download and install Mingw482_32 for the compiler?
    What about a debugger? It looks like the Qt kit configuration includes a place to define a debugger, also.

    Thanks again.



  • What package did you download exactly?



  • I went to the web site and clicked on the download button. I was asked if I wanted to download or run. I selected run. The installation ran without any problems at all.

    The filename associated with the download button was qt-opensource-windows-x86-1.6.0-5-online.exe


  • Lifetime Qt Champion

    Ok, that's the online installer.

    What did you select exactly when you installed Qt ?



  • I don't remember seeing any options during the installation. After I started the installation, it ran to completion and ended with a screen showing two checkboxes. One was to see the readme file and the other was to launch the application. I left both checked and read through the readme file and closed it. The application started then with the default launch screen.

    One thing I noticed when looking through the Tools -> Options -> Build and Run -> Kits is the following lines:

    Auto-detected
    qt-opensource-windows-x86-1.6.0-5-online.exe
    Qt 5.3 for Windows Phone 8 arm MSVC2012 32bit
    Qt 5.3 for Windows Phone 8 x86 MSVC2012 32bit (Emulator)
    Qt 5.3 for Windows Runtime 64bit

    These all had a red stop sign in front of the entries. If I click on the top entry, it shows no compiler selected. The line for the compiler is grayed out. The Manage button is available, though, and when I select it, it goes to the Compiler tab and shows

    Auto-detected
    MinGW 4.8.2 32bit MinGW

    I tried to select it and click on apply but the compiler in the Kit tab is still empty. It's like it sees the compiler is there but doesn't want to accept it.


  • Lifetime Qt Champion

    You can't mix and match compilers like that.

    You installed Qt for Windows Phone 8 built with MSVC2012, so you need Visual Studio 2012 installed to use them.



  • OK. Now I'm really confused. I didn't even want to develop any applications for Windows Phone 8, etc. I only wanted to develop an application to run on a Windows 7 desktop or laptop. I don't know how MSVC got selected as the compiler, etc.

    So what do I need to do to get an environment where I can compile and debug programs using my Windows 7 machine for a Windows 7 target using the MinGW 4.8.2 32bit MinGW compiler? Do I need to download and install the MinGW compiler first and then download and install the QtCreator? Do I need to completely uninstall Qt first?

    Thanks for taking the time with me... I'll get it... I swear I'll get it...


  • Lifetime Qt Champion

    No need to download it separately, you should get it through the online installer also.

    However, the most simple way: remove everything, download the MinGW package and install it, then you should only have one version of Qt. It's a bit less practical for updates, but you'll have a complete setup



  • I went to Tools -> Options... -> Kits and tried to remove all the entries. I was unable to remove anything listed under Auto-detected. The remove option was not available for these entries.

    I have downloaded the mingw-get-setup.exe program but have not installed it yet. This was the latest download from their main web page.

    Do I need to completely uninstall the Qt environment before installing the MinGW program and then reinstall the Qt environment?


  • Lifetime Qt Champion

    Don't install MinGW separately. Do it either through Qt's online installer, or get the off-line installer Qt MinGW package.

    Since your installation seems a bit off, just uninstall everything and start from scratch.



  • From the downloads page, there is a which titled "Qt Online Installer for Windows (14 MB) (Info)" which runs the online installer. This was based on an assessment made of my machine which stated this was the suggested download for my operating system.

    If I click on the button to show other versions available, there are titles including "Qt 5.3.2 for Windows 32-bit (MinGW 4.8.2, OpenGL, 737 MB)", "Qt 5.3.2 for Windows 32-bit (VS 2010, OpenGL, 539 MB)", etc.

    Are you saying to run the download for Qt 5.3.2 for Windows 32-bit(MinGW 4.8.2, OpenGL, 737MB)? Will this install the MinGW compiler also or do I need to get that from a different source? Will this be all that is needed to get a working environment under Windows 7 for Windows 7 targets?

    Thanks, again.



  • I downloaded and installed Qt 5.3.2 for Windows 32-bit (VS 2010, OpenGL, 539 MB) from the list. In trying to run it, the compiler was still not seen.

    I downloaded and installed Microsoft Visual Studio 2013 Express. When I launched the Qt installation, it found the Microsoft compiler. I was able to compile and execute the simple example application.

    The kit description showed the Microsoft compiler but no debugger was listed.


  • Lifetime Qt Champion

    If you install the VS 2010 package you need to also have Visual Studio 2010 installed. You can't mix and match Microsoft compilers. The corresponding debugger is an additional download that you have to, again, get from Microsoft.



  • ...oops... I meant I downloaded and installed the VS2013, not the VS2010, version. The Microsoft Visual Studio Express is the 2013 version, also.

    What file would I download from Microsoft for the debugger? Could I get Qt to recognize the debugger included with the Express 2013 version?

    Thanks for your help. It looks like I'm finally on my way to get some programming done... :)


  • Lifetime Qt Champion

    The Microsoft debugging tools


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.