"SOLVED: Extra characters after test expression" problem



  • I have read the suggested solutions listed on the web without finding an answer.
    Here is the error message from the compiler...and below it, the code itself from "QtTracker3.pro"
    Any help greatly appreciated!

    15:49:08: Running steps for project QtTracker3...
    15:49:08: Starting: "C:\Qt\Qt5.3.0\5.3\msvc2013_64_opengl\bin\qmake.exe" D:\AllProgrammingProjs\QtGUIProjects\QtTracker3\QtTracker3.pro -r -spec win32-msvc2013 "CONFIG+=debug"
    D:/AllProgrammingProjs/QtGUIProjects/QtTracker3/QtTracker3.pro:42: Extra characters after test expression.
    Error processing project file: D:\AllProgrammingProjs\QtGUIProjects\QtTracker3\QtTracker3.pro
    15:49:09: The process "C:\Qt\Qt5.3.0\5.3\msvc2013_64_opengl\bin\qmake.exe" exited with code 3.
    Error while building/deploying project QtTracker3 (kit: Desktop Qt 5.3.0 MSVC2013 OpenGL 64bit)
    When executing step 'qmake'
    15:49:09: Elapsed time: 00:00.

    @#-------------------------------------------------

    Project created by QtCreator 2014-11-02T09:55:35

    #-------------------------------------------------

    QT += core gui

    greaterThan(QT_MAJOR_VERSION, 4): QT += widgets

    TARGET = QtTracker3
    TEMPLATE = app

    SOURCES += main.cpp
    dialog.cpp

    HEADERS += dialog.h

    FORMS += dialog.ui

    INCLUDEPATH += C:\OpenCV2.2\lib
    INCLUDEPATH += C:\OpenCV2.2\include
    INCLUDEPATH += C:\OpenCV2.2\include\opencv
    INCLUDEPATH += C:\OpenCV2.2\include\opencv2
    INCLUDEPATH += C:\OpenCV2.2\bin

    LIBS += -LC\OpenCV2.2\lib\debug
    -lopencv_calib3d220d
    -lopencv_contrib220d
    -lopencv_core220d
    -lopencv_features2d220d
    -lopencv_ffmpeg220d
    -lopencv_flann220d
    -lopencv_gpu220d
    -lopencv_highgui220d
    -lopencv_imgproc220d
    -lopencv_legacy220d
    -lopencv_ml220d
    -lopencv_objdetect220d
    -lopencv_ts220d
    -lopencv_video220d
    @


  • Lifetime Qt Champion

    Hi,

    One thing that looks strange:

    @-LC\OpenCV2.2\lib\debug@

    You are missing the colon. However, even if you're on windows, use forward slashes for path

    so:

    @-LC:/OpenCV2.2/lib/debug @



  • Thanks for speedy reply. I tried both your suggestion, but they didn't work.I'm open to any other ideas!!

    Thanks!
    Bob



  • Hi.
    In your .pro file you are not enclosing INCLUDEPATH (s) by " ..//Path//include"

    Please enclose them and build again.



  • Appreciate the continued help. I tried the previous suggestions, but unfortunately none have corrected the problem. (I forgot to acknowledge that SGaist was right about the ":" after the C in line 28. I'm thinkin' it's a PATH problem, although I have no idea why!



  • DUH!!! Found the problem. Line 34 missing the " \ " (line continuation character) corrected this problem. As usual, it's something simple!! Now, I get to try and figure out the other new problems listed. Thanks again.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.