Problem with OpenCV3.0 and Qt creator



  • Hello, I need to use OpenCV with Qt creator, and need some help with OpenCV.

    My problem occurs when I run any example or .exe made with OpenCV, after I install OpenCV with CMake (and checking WITH_QT in the process).

    For example with the examples included in the installation, when I try to open one I get the following error:

    !http://answers.opencv.org/upfiles/1413994743487541.png(The error)!

    That says: Procedure entry point not found in the dynamic links library

    My S.O. is Windows 8.1, 64 bits

    I have tried to reinstall Qt and install differents versions, but the error is the same ever.

    But, if I install OpenCV with CMake and don´t check WITH_QT, the examples works perfectly.

    I dont know what else can I do!
    Thanks!


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Might be a silly question: did you check that the example can find the Qt libraries you used to build OpenCV ?

    You can check using e.g. Dependency Walker



  • make sure

    1. the folder storing Qt dll files is included in the environment variable PATH
    2. the folder storing OpenCV dll files is included in the environment variable PATH

  • Lifetime Qt Champion

    Putting the path to Qt's dlls in the PATH environment variable is a bad idea. You don't know whether other applications on your system also use Qt and they'll start using the one from PATH rather than their own bundled version.



  • How to avoid copying Qt's dlls many times if PATH environment variable is not used?


  • Lifetime Qt Champion

    In the case of a standard use of your computer, you'll probably already have several copies of Qt depending on what application you installed.

    While developing the problem doesn't occur if you use e.g. Qt Creator since it modifies the environment as needed for your application to run.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.