Important: Please read the Qt Code of Conduct -

[SOLVED]:Qt Creator can't find header files from C++ STL library

  • Hello,
    I am relatively new to Qt development and have purchsed the Embedded Enterprise version of Qt. I have used the online installer to install Qt 5.3 and am targeting an embedded linux device (Sabre SD i.MX6) platform. I can successfully build my application for a desktop build but when I build for the target embedded device I get compile errors in that it can not find <utility>. From my understanidng this is a C++ standard template library file that can not be found. I have installed and verified that the g++ compiler is present. It was my impression that when I downloaded and installed the Enterprise binaries that everything was ready to go for the embedded device. When I ran the evaluation of Qt Enterprise I didn't run into these types of problems.

    Any thoughts on what is not setup correctly and is causing my frustration? Any help would be appreciated.


  • Hey, ~kripperda!

    Welcome to Qt Developer Network. As far as I understood, your Qt Creator setup can't see STL libraries. It's most probably caused by invalid "Build & Run" settings, so you would better start with looking carefully, which Kit is used for your current project. Then, make sure that compiler, linked to this Kit actually exists and its include headers are present.

  • To my knowledge, everything looks to point to the correct build kit for my project.

    The compiler path is

    qmake is located at:

    This came pre-packaged with the binaries I downloaded for the Enterprise version of Qt, so I would expect that everything is correctly there.

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    To add to tucnak, since you are using a commercial product, you should also ask the commercial support for help

  • Update - Resolved: Issue was a mis-configured compiler flag in the project file

    I had overwritten the CXXFLAGS with
    QMAKE_CXXFLAGS = -Wmissing-field-initializers
    when it should have been a +=: QMAKE_CXXFLAGS += -Wmissing-field-initializers to add instead of overwrite

  • Lifetime Qt Champion

    Nice you found out and thanks for sharing.

    Since you have it working now please update the thread title prepending [solved] so other forum users may know a solution has been found :)

Log in to reply