Unable to Add Third party library



  • Hi,

    I am trying to add and android library to my qt android project. But it fails while deploying.
    I followed steps as given in documentation : "Third-party Android Libraries":http://qt-project.org/doc/qt-5/android3rdpartylibs.html

    I get the error

    BUILD FAILED
    E:\Installations\ADT\adt-bundle-windows-x86-20131030\sdk\tools\ant\build.xml:577: ../android-build/libs/ resolve to a path with no project.properties file for project E:\WorkSpaces\Qt\Qt_WidgetApps\AndroidSerialPortTrials\ThirdPartyLib\build-ThirdPartyLib-Android_for_armeabi_v7a_GCC_4_8_Qt_5_3_0_Android_GCC_arm_4_8-Debug\android-build

    my project.properties

    android.library.reference.1=../android-build/libs/

    projectPath/android/

    • libs
    • AndroidManifest.xml
    • project.properties

    projectPath/android/libs/

    I tried
    android.library.reference.1=libs/ as given in documentation
    android.library.reference.1=../android/libs/
    android.library.reference.1=./libs/

    But all gives error



  • The library you want to include is provided as .JAR file or as Android project ??



  • .jar file



  • So, you don't need to do anything !!
    Just put the .jar file into the android/lib source and that's it.
    Remove any project.properties you created, because you don't need to indicate any android.library.reference

    That instructions are for the case where the library is given to you as android project and need to be compiled.



  • oh.. so now what I need to do is call java with qandroidextras?

    Thanks a lot



  • Yes ! ... and please... mark this topic as solved if you are able to use the library.



  • sure.. ill check this and update in the header


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.