QtCreator 2.8.1 question



  • Hi all, I've been using QtCreator 2.8.1 with Qt 4.8.4 and need to start working with Qt 5.2.1. I don't want to go to QtCreator 3 because the qml designer specific file structure has changed, and I have about 30 QML controls I use and don't want to rewrite the specifics file for each one right now.

    Anyways I downloaded and built Qt 5.2.1 on Mint Mate 32 bit and added Qt 5.2.1 to my Qt Versions in QtCreator and created another kit. I thought all would be well until I tried to create a simple Qt Quick 2 Extension Plugin. The intellisense and code completion is not working if I try and use the Qt 5.2.1 kit.

    Does anybody have any suggestions on how to get code completion and intellisense to work? The plugin compiled with no issues, I kind of need the intellisense and code completion to work. QtCreator puts a line under all the include statements like it can't find them, but yet it compiles with no issues.

    Thanks


  • Lifetime Qt Champion

    Hi,

    AFAIR, Qt 5.2 requires Qt Creator 3 or upper for the features you need as well as to run application. However I don't remember the why exactly.



  • Thank you SGaist, I went to 5.1.1 and all is well.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.