Problem with start App [solved]



  • Hi, i have problem with my Qt5.3.1. I installed JDK,SDK,NDK and Ant for Android next to i install Library and Emulator.
    Then I wanted to run apps, and get an error:

    install_target Error 1 (ignored);

    I do not know what I do now I installed the same android on another computer and there everything works. In here gives me all the time this mistake You may have some ideas what could be causing


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You should add what OS you are running on, Qt Creator's version as well as a full log of what happens before this error



  • 09:55:15: Running steps for project nienazwany2...
    09:55:15: Configuration unchanged, skipping qmake step.
    09:55:15: Starting: "C:\Qt\Tools\mingw482_32\bin\mingw32-make.exe"
    mingw32-make: Nothing to be done for 'first'.
    09:55:15: The process "C:\Qt\Tools\mingw482_32\bin\mingw32-make.exe" exited normally.
    09:55:15: Removing directory D:/Qt workspace/build-nienazwany2-Android_dla_armeabi_v7a_GCC_4_8_Qt_5_3_1-Release/android-build
    09:55:15: Starting: "C:\Qt\Tools\mingw482_32\bin\mingw32-make.exe" INSTALL_ROOT="D:/Qt workspace/build-nienazwany2-Android_dla_armeabi_v7a_GCC_4_8_Qt_5_3_1-Release/android-build" install
    /usr/bin/sh: test: D:/Qt: binary operator expected
    cp -f "libnienazwany2.so" "D:/Qt workspace/build-nienazwany2-Android_dla_armeabi_v7a_GCC_4_8_Qt_5_3_1-Release/android-build/libs/armeabi-v7a/libnienazwany2.so"
    cp: cannot create regular file `D:/Qt workspace/build-nienazwany2-Android_dla_armeabi_v7a_GCC_4_8_Qt_5_3_1-Release/android-build/libs/armeabi-v7a/libnienazwany2.so': No such file or directory
    Makefile:1570: recipe for target 'install_target' failed
    mingw32-make: [install_target] Error 1 (ignored)
    09:55:16: The process "C:\Qt\Tools\mingw482_32\bin\mingw32-make.exe" exited normally.
    09:55:16: Starting: "C:\Qt\5.3\android_armv7\bin\androiddeployqt.exe" --input "D:/Qt workspace/build-nienazwany2-Android_dla_armeabi_v7a_GCC_4_8_Qt_5_3_1-Release/android-libnienazwany2.so-deployment-settings.json" --output "D:/Qt workspace/build-nienazwany2-Android_dla_armeabi_v7a_GCC_4_8_Qt_5_3_1-Release/android-build" --deployment bundled --install --ant C:/Users/Bartek/Desktop/apache-ant-1.9.4/bin/ant.bat --android-platform android-20 --jdk "C:/Program Files/Java/jdk1.8.0_20" --device CB5A1XHJ7N
    09:55:16: Pulling files necessary for debugging.
    09:55:16: Package deploy: Running command 'C:/Users/Bartek/Desktop/adt-bundle-windows-x86_64-20140702/sdk/platform-tools/adb.exe -s CB5A1XHJ7N pull /system/bin/app_process D:/Qt workspace/build-nienazwany2-Android_dla_armeabi_v7a_GCC_4_8_Qt_5_3_1-Release/app_process'.
    09:55:16: Package deploy: Running command 'C:/Users/Bartek/Desktop/adt-bundle-windows-x86_64-20140702/sdk/platform-tools/adb.exe -s CB5A1XHJ7N pull /system/lib/libc.so D:/Qt workspace/build-nienazwany2-Android_dla_armeabi_v7a_GCC_4_8_Qt_5_3_1-Release/libc.so'.
    Generating Android Package
    Input file: D:/Qt workspace/build-nienazwany2-Android_dla_armeabi_v7a_GCC_4_8_Qt_5_3_1-Release/android-libnienazwany2.so-deployment-settings.json
    Output directory: D:/Qt workspace/build-nienazwany2-Android_dla_armeabi_v7a_GCC_4_8_Qt_5_3_1-Release/android-build
    Application binary: D:/Qt workspace/build-nienazwany2-Android_dla_armeabi_v7a_GCC_4_8_Qt_5_3_1-Release/libnienazwany2.so
    Android build platform: android-20
    Install to device: CB5A1XHJ7N
    Application binary is not in output directory: D:/Qt workspace/build-nienazwany2-Android_dla_armeabi_v7a_GCC_4_8_Qt_5_3_1-Release/android-build/libs/armeabi-v7a/libnienazwany2.so. Please run 'mingw32-make install INSTALL_ROOT=D:/Qt workspace/build-nienazwany2-Android_dla_armeabi_v7a_GCC_4_8_Qt_5_3_1-Release/android-build' first.
    09:55:17: The process "C:\Qt\5.3\android_armv7\bin\androiddeployqt.exe" exited with code 7.
    Error while building/deploying project nienazwany2 (kit: Android dla armeabi-v7a (GCC 4.8, Qt 5.3.1))
    When executing step "Zainstaluj na urządzeniu Android"
    09:55:17: Elapsed time: 00:02.


  • Lifetime Qt Champion

    First thing I would do is rename Qt workspace to Qt_workspace. Spaces in path on Windows are problematic.



  • I changed name this folder, I removed the spaces. I also found the settings in qt Anroid something like this (warrning):

    Qt version for mips architecture is missing. To add the qt version, select Options> Build & Run> Qt Versions



  • I reinstalled qt and everything now works correctly


  • Lifetime Qt Champion

    Nice !

    Since it's working now, please update the thread title prepending [solved] so other forum users may know a solution has been found :)

    Happy coding :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.