Qt developed on OS X 10.6 for iPhone and iPad, which qt to choose 4 or 5



  • Hi,

    I need to compile and deploy my applications for iPhone and iPad, I don't need to publish them at Apple Store at this point. I have written my app using Qt 4.8 but recently upgraded to 5.2.1.

    I have computer with Mac OS X 10.6 available for me and it is not clear to me whether:

    1. Can I use Qt 5.2.1 on Mac OS X 10.6 ?
      This page: http://qt-project.org/doc/qt-5/ios-support.html
      says I should be using Xcode 5 (that works on 10.8 or 10.9)
      and for 10.6 latest Xcode is 4.2 I think

    2. If Qt 5.2 and Mac OS X 10.6 won't work is it possible to use XCode 4.2 Qt 4.8 and compile and deploy on iPhone and iPad (v 4 and 5)

    best regards
    Marek



    1. You need OS X 10.8 for use Qt 5.2.1
      but
    2. You can use Qt 4.8 and Xcode 4.2 and deploy on all iPhone and iPad. But it's forbidden by Apple policy to publish on the store an app developed with version of Xcode 4.x and before and iOS Sdk 6.x and before.


  • Thanks,

    So, If I don't need Apple Store, I can deploy on locally connected devices from Mac OS 10.6 with Qt 4.8

    Thanks
    Marek


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.