Qt HTML5 Project, No remote content



  • Hello all. Hopefully I've chosen the correct location, I assume Qt WebKit is the Qt HTML5 Application type.
    I have searched for an answer for a couple days now, so if it already exists, please just point me to it!

    I have an HTML5 project, where most of the UI is simply html/js/css. The application is now working flawlessly on Windows 32 bit. However, when I run it on Windows 64 bit, anything that's an external url (not an image, etc within my application's html folder) nothing loads.
    We have both some images that load from "external" url's, i.e.:
    http://stag1-vms.hovrs.com:8080/api/request?api=exportContent&path=PSE.VAM/spool/mb/93/2/m_20140818134906_41997&format=jpg_cif
    (Yes, just a black image, bad example, but I get it on 32b and not 64b)
    And some videos:
    http://stag1-vms.hovrs.com:8080/api/request?api=exportContent&path=PSE.VAM/spool/mb/93/2/m_20140818134906_41997&format=flv_cif_3840

    Like I said, they load up just fine, playback, etc on 32b Windows, but not 64b. If I use the web inspector on 64b, it shows Status 200 OK on the GET in Network tab, but I just get the question marks displayed :(
    Maybe just an option I have to set on the webView object? Am I going to have to actually make a 64b version of my app? (If so, any good instructions on that? It's my first time in general with QT, BTW, using QT Creator, QT 5.3.1, MinGW 32b)

    The videos are not too important as I'm working on a player on the Qt side and have access to other formats.
    Thanks! :)


  • Lifetime Qt Champion

    Hi,

    How are you checking on your 64 bit windows ? Deploying the application or also building on it ?



  • Just deploying for test (on Windows 64). I Windows 7 32 is my main dev machine for this, I then have a plain Windows 64 with nothing other than anti-virus I use to test the app on 64b, and to test the installer itself. Someone else with Windows 7 64b originally reported it.


  • Lifetime Qt Champion

    Then check that you deploy all required plugins like e.g. the bearer plugins



  • It worked! Thanks. :) I had to grab (maybe, grabbed it anyways since you mentioned it) bearer, and in particular imageformats.
    Yay!
    The only thing as far as I can tell that's not working now is the flash plugin. On my dev machine (Win32) of course, it works. On the Win64, it's giving me the blue lego block.
    How does that work in at Qt project like this, I assume since i just had to enable plugins to get the support on my dev box, it was self contained. Now I'm wondering if I have to bundle flash or something.
    In the long run, I'm trying to bring the video playback into the Qt side of things, but that's not working out well so far.


  • Lifetime Qt Champion

    You're welcome :)

    Did you install the flash plugin on your Win64 box ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.