QtCreator not changing file list



  • So I've searched for the past two hours to try to find an answer or solution to this problem and have gotten nowhere.

    The project I'm working on (cannot describe due to businessy stuff) is using CMake and CCmake and until now I've had no problem opening the project in QtCreator via CMakeLists.txt. It has come to pass that I misnamed one of the files and had to change the name of it. I went through every file #include-ing it and changed the name and changed all instances of the name to the new name. Then I modified the CMakeLists.txt file in the folder containing the changed file to contain the new file name. Went to the base folder of the project and re-generated all the files as I always have and everything went fine until I reopened the project. The old files were still in the list and the new files were not. When I tried to open the files in the list, they wouldn't open, since they had been renamed (duh), but I have no idea why the new files won't show up. I even tried modifying the parameters of CCMake to not even include the section I was trying to build and it still opened the files in QtCreator. I have been unable to progress on my work due to this, and I would really appreciate a resolution.

    A few things I tried:
    Rebooting
    Redoing cmake
    redoing ccmake
    redoing ccmake and cmake (in both orders)
    building a different section of the project and not the one I'm working on (Note: The other section which has always worked fine also did not show up)

    Side note: I'm using a VM of Ubuntu running on Windows 8 that I moved from another machine, but (possibly) until now, that has not been a problem.

    Thanks,

    Michael



  • Hi,
    You might want to post this topic to the Tools forum, this is more a general widget/Qt forum. You might get better response there.
    Greetz


  • Lifetime Qt Champion

    Hi again,

    It seems there was some glitch.
    I moved it again and just for the record (and other people coming here): don't duplicate post, you can ask to have them moved by a moderator.

    Also, here the solution again: remove the CMakeList.txt.user

    Happy coding



  • And again, since it glitched. Thank you for your help, it worked perfectly.


  • Lifetime Qt Champion

    Again, you're welcome :)

    Can you also update the thread title prepending [solved] so other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.