Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[Solved] How to prevent QT library project generating so, so.1 so.1.0 etc.....



  • I have my library project and when build it it creates so, so.1 so.1.0 so.1.0.0 files (on windows)
    It is annoying I would like to have only .so
    I bet it is some sort of qmake setting, I just cannot figure out what is it.

    Thank you.


  • Lifetime Qt Champion

    Hi,

    There's something not quite clear here, you are running windows and get so files when building a library ?

    What version of Qt are you using ?
    Can you show your pro file ?



  • There is nothing wrong with building libraries for ARMLEV7 on windows :)

    built for QNX, QT 5.3.1, QT Creator 3.1.2

    Here is my pro file, it super simple:

    @# The name of the library
    TARGET = mylib

    Compile a .so, not a binary

    TEMPLATE = lib

    Libraries we need

    LIBS += -L"$${FRAMEWORK_BUILD_LIBS}" -lqcore

    QT libraries we need

    QT += core

    HEADERS +=
    mylib.h

    SOURCES +=
    mylib.cpp@


  • Lifetime Qt Champion

    No, indeed, there's not, but it's an information that you should have mentioned in the first place ;)

    IIRC, you can add CONFIG += plugin to avoid the numbering but it's not really good practice.



  • [quote author="SGaist" date="1408464985"]
    IIRC, you can add CONFIG += plugin to avoid the numbering but it's not really good practice.[/quote]
    Yes, you are right, next time will add details for sure!

    This method sounds like a bit of workaround/hack... interesting what will be an implication of using such config option on my library?



  • Just tested and it worked, thank you !!!! Size of library was not changed from the previous setup so I assume there is no implications.


  • Lifetime Qt Champion

    It is a workaround because you are doing something that's not correct ;)

    Since you have it working now, please update the thread title prepending [solved] so other forum users may know a solution has been found :)



  • Sure! But is that the only way ? It is kind of surprising that there is no way to modify it properly, why it generate all those files at first place 4 times ? Can I do something in mkspecs or qmake.conf ?


  • Lifetime Qt Champion

    Like I said, you are going against linux standards for library handling

    "Here":http://www.ibm.com/developerworks/linux/library/l-shlibs/index.html are more informations about that


Log in to reply