[SOLVED] QTWebEngine not building on OSX 10.9



  • Hello.

    I just trying to compile QTWebEngine and getting this error when running make command:

    In file included from ../../../src/3rdparty/chromium/third_party/webrtc/modules/audio_coding/codecs/g711/g711_interface.c:11:
    In file included from ../../../src/3rdparty/chromium/third_party/webrtc/modules/audio_coding/codecs/g711/g711.h:52:
    ../../../src/3rdparty/chromium/third_party/webrtc/typedefs.h:89:34: error: unknown warning group '-Wc++11-extensions', ignored [-Wunknown-pragmas]
    #pragma clang diagnostic ignored "-Wc++11-extensions"
    ^
    1 diagnostic generated.
    [6/9673] CC obj/src/3rdparty/chromium/third_party/libwebp/demux/libwebp_demux.demux.o
    clang: warning: argument unused during compilation: '-fcolor-diagnostics'
    clang: warning: argument unused during compilation: '-fstack-protector-all'
    warning: unknown warning option: -Wheader-hygiene
    warning: unknown warning option: -Wno-c++11-narrowing
    warning: unknown warning option: -Wno-unneeded-internal-declaration
    warning: unknown warning option: -Wno-covered-switch-default
    warning: unknown warning option: -Wstring-conversion
    warning: unknown warning option: -Wno-deprecated
    warning: unknown warning option: -Wno-header-hygiene
    [6/9673] CXX obj/src/3rdparty/chromium/third_party/smhasher/src/cityhash.City.o
    ninja: build stopped: subcommand failed.
    make[4]: *** [invoke_ninja] Error 1
    make[3]: *** [debug-all] Error 2
    make[2]: *** [sub-gyp_run-pro-make_first] Error 2
    make[1]: *** [sub-core-make_first] Error 2
    make: *** [sub-src-make_first] Error 2

    I'm using Qt5.3.1 and clang64 compiler.

    Did anybody faced with similar issue?



  • Sorry, my bad, I just had 'old' clang in my $PATH.


  • Lifetime Qt Champion

    Hi,

    Glad you found out and thanks for sharing. Can you also please update the thread title prepending [solved] so other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.