problem related to the file .exe



  • I have started a project in Qt Creator but when compile it poster this message:

    Executable C:\Qt\Tools\QtCreator\bin\build-tpzero2-Desktop_Qt_5_3_MinGW_32bit-Debug\debug\tpzero2.exe does not exist.

    Can somebody help me and thanks.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Do you have an antivirus running ? If so, try to disable it and rebuild your application, some antivirus software tends to think that self compiled application are a threat



  • i have disabled the antivirus as you said but the problem is not solved



  • Is tpzero2 your project?
    Why is it located in QtCreator directory *C:\Qt\Tools\QtCreator\bin* ?



  • Yes it is.I think the path is not the problem because I have other projects with the same path .



  • You have other projects and they work correctly. Is it right?

    After you built tpzero2 and got "C:\Qt\Tools\QtCreator\bin\build-tpzero2-Desktop_Qt_5_3_MinGW_32bit-Debug\debug\tpzero2.exe does not exist." did you check if the file exists?

    What does "Projects/Run Settings" says about executable file?
    If you try to create a simple Qt App do you have similar error?

    Could you post .pro file.



  • Yes they all work correctly.

    For this project only the icon exist but for the other projects there are icon with the name of the project.
    I have tried to create a Qt App and there are no errors.

    .pro file :
    @
    TEMPLATE = app
    QT += webkitwidgets
    TARGET =
    DEPENDPATH += .
    INCLUDEPATH += .

    SOURCES +=
    main.cpp
    FenPrincipale.cpp

    HEADERS +=
    FenPrincipale.h
    @

    I have took a screen capture for the run settings but I don't know how I post it

    [andreyc EDIT]: Added '@' around the code.



  • I think TARGET should not be empty.

    You can put image to http://imgbox.com/ for example and put a link here.





  • Thank you very much for the help #andreyc. As you said the problem is in the target because when I put TARGET as a comment the problem is solved.
    Thank you again.



  • Thank you also #SGaist.



  • Hi, sorry for answering to this old post, but I think It could be usefull.

    In my case, I had the same error "Executable *****.exe does not exist."

    In order to find a solution, I executed the .exe directly from the Debug folder, and in this case, an error appears: "Program cannot start because a ***.dll is missing", so the problem was there, I miss to include a neccessary DLL into the debug folder, and the Qt IDE Creator didn't give you that information. Once the .dll was placed in the folder, everytning worked fine.

    I hope this could be usefull for someone in the future.

    Thanks.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.