[SOLVED] Qt build problem



  • I can't build any program in Qt. I'm running it on Windows 8, I open Qt Creator with admin rights, I tried to use mingw and VC++ as compiler and I get the error:
    @16:17:32: Running steps for project untitled...
    16:17:32: Starting: "C:\Qt\Qt5.3.1\5.3\msvc2013_64_opengl\bin\qmake.exe" C:\Qt\Qt5.3.1\Tools\QtCreator\bin\untitled\untitled.pro -r -spec win32-msvc2010 "CONFIG+=debug"
    16:17:32: The process "C:\Qt\Qt5.3.1\5.3\msvc2013_64_opengl\bin\qmake.exe" exited normally.
    16:17:32: Starting: "C:\Qt\Qt5.3.1\Tools\QtCreator\bin\jom.exe"
    C:\Qt\Qt5.3.1\Tools\QtCreator\bin\jom.exe -f Makefile.Debug
    C:\Qt\Qt5.3.1\5.3\msvc2013_64_opengl\bin\uic.exe ..\untitled\mainwindow.ui -o ui_mainwindow.h
    jom: C:\Qt\Qt5.3.1\Tools\QtCreator\bin\build-untitled-QT-Debug\Makefile.Debug [ui_mainwindow.h] Error 2
    cl -c -nologo -Zm200 -Zc:wchar_t -Zi -MDd -GR -W3 -w34100 -w34189 -EHsc /Fddebug\untitled.pdb -DUNICODE -DWIN32 -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I"........\5.3\msvc2013_64_opengl\include" -I"........\5.3\msvc2013_64_opengl\include\QtWidgets" -I"........\5.3\msvc2013_64_opengl\include\QtGui" -I"........\5.3\msvc2013_64_opengl\include\QtCore" -I"debug" -I"." -I"." -I"........\5.3\msvc2013_64_opengl\mkspecs\win32-msvc2010" -Fodebug\ @C:\Users\Tomasz\AppData\Local\Temp\main.obj.3416.16.jom
    main.cpp
    C:\Qt\Qt5.3.1\5.3\msvc2013_64_opengl\bin\moc.exe -DUNICODE -DWIN32 -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -D_MSC_VER=1600 -D_WIN32 -IC:/Qt/Qt5.3.1/5.3/msvc2013_64_opengl/mkspecs/win32-msvc2010 -IC:/Qt/Qt5.3.1/Tools/QtCreator/bin/untitled -IC:/Qt/Qt5.3.1/5.3/msvc2013_64_opengl/include -IC:/Qt/Qt5.3.1/5.3/msvc2013_64_opengl/include/QtWidgets -IC:/Qt/Qt5.3.1/5.3/msvc2013_64_opengl/include/QtGui -IC:/Qt/Qt5.3.1/5.3/msvc2013_64_opengl/include/QtCore -I. ..\untitled\mainwindow.h -o debug\moc_mainwindow.cpp
    jom: C:\Qt\Qt5.3.1\Tools\QtCreator\bin\build-untitled-QT-Debug\Makefile.Debug [debug\moc_mainwindow.cpp] Error 2
    jom: C:\Qt\Qt5.3.1\Tools\QtCreator\bin\build-untitled-QT-Debug\Makefile [debug] Error 2
    16:17:33: The process "C:\Qt\Qt5.3.1\Tools\QtCreator\bin\jom.exe" exited with code 2.
    Error while building/deploying project untitled (kit: QT)
    When executing step 'Make'@

    I tried to reinstall Qt, but nothing else happened.



  • Welcome to Qt DevNet

    There is no actual error message in the log you provided.
    Could you post the lines with a compiler errors.

    Please check that you use correct Qt versions with right compilers.
    Qt MinGW will not work with Visual Studio and vice versa.
    A mix of 32 and 64 bit binaries will not work also.



  • I have Qt 5.3.1 for Windows 64-bit (VS 2013) and VS 2013. I don't know from where I should take a compiler errors.
    Screenshots:
    http://iv.pl/images/45032076509595743730.png
    http://iv.pl/images/93238453949783113534.png
    http://iv.pl/images/37617543725931403424.png



  • Hi, you could try installing Qt using the online installer.



  • Thanks,I've been doing it for about 2h ;) I don't know why download speed is so slow ~70 KBps.
    I am really nice suprised, how fast you try to help average newbie user. Thanks.


  • Lifetime Qt Champion

    Hi,

    You might be connected to a faulty mirror, "this":https://github.com/JKSH/QtSdkRepoChooser may help



  • I have downloaded it and Mingw 32 version only works. Thanks and [SOLVED]


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.