[SOLVED] Qt Creator 3.1.2 Won't Add Older Qt Versions



  • Using the downloaded dmg file, I installed Qt 5.3.1 on my Mac running Mavericks and with it came Creator 3.1.2. I also installed Qt 4.8.6 from its dmg file. The 4.8.6 install spread the files over the usual Mac directories under /Developer .

    When I try to get Creator 3.1.2 to add the 4.8.6 version to its list, a file chooser dialog pops up from which I navigate to gmake in /Developer/Tools/Qt. The file chooser sees the gmake alias, but won't recognize it as a stand in for the executable. I see no way to have the file chooser get to the executable in /usr/bin . So, what do I do to get it to recognize qmake? I could move the executable to /Developer/Tools/Qt, but I'm not sure that would work in the long run.

    All of the on-line Qt documentation deals with older versions of Creator where it appears the adding version dialog works differently.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    To go the /usr/bin you need to reveal the hidden folders when browsing the dialog. Go to the root of the volume and press CMD + Shift + .



  • Thanks! That worked. I knew there had to be some "little known" keystroke sequence.


  • Lifetime Qt Champion

    You're welcome !

    Now that you have your old Qt working, please update the thread title prepending [solved] so other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.