QT Mysql cant compile Plugin



  • Hello all,

    i tried to compile the mysql plugin for the raspberry pi. I cross compile it on a ubuntu maschine.

    i get following error:

    @/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf-g++ -Wl,-rpath-link,/mnt/rasp-pi-rootfs/opt/vc/lib -Wl,-rpath-link,/mnt/rasp-pi-rootfs/usr/lib/arm-linux-gnueabihf -Wl,-rpath-link,/mnt/rasp-pi-rootfs/lib/arm-linux-gnueabihf --sysroot=/mnt/rasp-pi-rootfs -Wl,--no-undefined -Wl,-O1 -Wl,-rpath,/usr/local/qt5pi/lib -shared -o libqsqlmysql.so .obj/main.o .obj/qsql_mysql.o .obj/moc_qsql_mysql_p.o -L/home/moe/mysql/lib -lmysqlclient -L/opt/qt5/qtbase/lib -lQt5Sql -lQt5Core -lpthread
    /home/moe/mysql/lib/libmysqlclient.so: file not recognized: File format not recognized
    collect2: error: ld returned 1 exit status
    make: *** [../../../../plugins/sqldrivers/libqsqlmysql.so] Fehler 1
    @

    i download this mysql dev mysql-connector-c-6.1.5-linux-glibc2.5-x86_64.tar.gz. Also tried libmysqlclient-dev. But i get the same issue. If you need any more information please ask.

    Thx best regards MOE


  • Lifetime Qt Champion

    Hi,

    Since you're cross-compiling, you need an ARM version of the mysql libraries



  • Hi,

    oh yes this is right. Thx


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.