Install QT Jambi on Mac OS X Mavericks



  • I'm trying to install QT Jambi on my Mac because I've fallen in love with it.

    But when I'm trying to install it via sh I get this message:

    @mm-air:qtjambi mm$ sh qtjambi.sh
    Exception in thread "main" java.lang.ExceptionInInitializerError
    at com.trolltech.qt.QtJambiObject.<clinit>(QtJambiObject.java:60)
    Caused by: java.lang.RuntimeException: Loading library failed, progress so far:
    Unpacking .jar file: 'qtjambi-macosx-gcc-4.7.0.jar'
    Checking Archive 'qtjambi-macosx-gcc-4.7.0.jar'

    • cache key='gcc-20101012-2105'

    • adding 'libQtCore.4.dylib' to library map

    • library: name='lib/libQtCore.4.dylib',

    • adding 'libQtGui.4.dylib' to library map

    • library: name='lib/libQtGui.4.dylib',

    • adding 'libQtXml.4.dylib' to library map

    • library: name='lib/libQtXml.4.dylib',

    • adding 'libQtSql.4.dylib' to library map

    • library: name='lib/libQtSql.4.dylib',

    • adding 'libQtSvg.4.dylib' to library map

    • library: name='lib/libQtSvg.4.dylib',

    • adding 'libQtNetwork.4.dylib' to library map

    • library: name='lib/libQtNetwork.4.dylib',

    • adding 'libQtHelp.4.dylib' to library map

    • library: name='lib/libQtHelp.4.dylib',

    • adding 'libQtScript.4.dylib' to library map

    • library: name='lib/libQtScript.4.dylib',

    • adding 'libQtScriptTools.4.dylib' to library map

    • library: name='lib/libQtScriptTools.4.dylib',
      ...

    • library: name='lib/libphonon.4.dylib',

    • library: name='plugins/phonon_backend/libphonon_qt7.dylib', never load

    • library: name='plugins/imageformats/libqjpeg.dylib', never load

    • library: name='plugins/imageformats/libqgif.dylib', never load

    • library: name='plugins/imageformats/libqmng.dylib', never load

    • library: name='plugins/imageformats/libqtiff.dylib', never load

    • library: name='plugins/imageformats/libqsvg.dylib', never load

    • library: name='plugins/iconengines/libqsvgicon.dylib', never load

    • library: name='plugins/codecs/libqcncodecs.dylib', never load

    • library: name='plugins/codecs/libqjpcodecs.dylib', never load

    • library: name='plugins/codecs/libqkrcodecs.dylib', never load

    • library: name='plugins/codecs/libqtwcodecs.dylib', never load

    • library: name='plugins/accessible/libqtaccessiblewidgets.dylib', never load

    • adding 'libqtjambi.jnilib' to library map

    • library: name='lib/libqtjambi.jnilib',

    • adding 'libcom_trolltech_qt_core.jnilib' to library map
      ...

    • library: name='lib/libcom_trolltech_qt_xmlpatterns.jnilib',

    • plugin path='plugins'

    • using cache directory: '/var/folders/16/fyg5mv952wj9j8l5_z89svbh0000gn/T/QtJambi_mm_x86_64_4.7.0_gcc-20101012-2105'

    • cache directory exists
      Loading library: 'libQtCore.4.dylib'...

    • using deployment spec

      at com.trolltech.qt.internal.NativeLibraryManager.loadNativeLibrary(NativeLibraryManager.java:431)
      at com.trolltech.qt.internal.NativeLibraryManager.loadQtLibrary(NativeLibraryManager.java:356)
      at com.trolltech.qt.Utilities.loadQtLibrary(Utilities.java:145)
      at com.trolltech.qt.Utilities.loadQtLibrary(Utilities.java:141)
      at com.trolltech.qt.QtJambi_LibraryInitializer.<clinit>(QtJambi_LibraryInitializer.java:56)
      ... 1 more
      Caused by: java.lang.UnsatisfiedLinkError: /private/var/folders/16/fyg5mv952wj9j8l5_z89svbh0000gn/T/QtJambi_mm_x86_64_4.7.0_gcc-20101012-2105/lib/libQtCore.4.dylib: dlopen(/private/var/folders/16/fyg5mv952wj9j8l5_z89svbh0000gn/T/QtJambi_mm_x86_64_4.7.0_gcc -20101012-2105/lib/libQtCore.4.dylib, 1): no suitable image found. Did find:
      /private/var/folders/16/fyg5mv952wj9j8l5_z89svbh0000gn/T/QtJambi_mm_x86_64_4.7.0_gcc-20101012-2105/lib/libQtCore.4.dylib: mach-o, but wrong architecture
      at java.lang.ClassLoader$NativeLibrary.load(Native Method)
      at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1929)
      at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1814)
      at java.lang.Runtime.load0(Runtime.java:809)
      at java.lang.Runtime.load(Runtime.java:797)
      at com.trolltech.qt.internal.NativeLibraryManager.loadLibrary_helper(NativeLibraryManager.java:458)
      at com.trolltech.qt.internal.NativeLibraryManager.loadNativeLibrary(NativeLibraryManager.java:426)
      ... 5 more@

    Thanks for every hint to solve this problem.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    I would say that

    @libQtCore.4.dylib: mach-o, but wrong architecture@

    is the hint you are looking for.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.