[solved] Recompile QTmultimedia with GStreamer plugin



  • Hi there,

    I just started QT programming for the Raspberry Pi, compiled Qt 5.3 as described in this guide: "RPI Beginners Guide":https://qt-project.org/wiki/RaspberryPi_Beginners_guide

    I compiled QTMultimedia like the tutorial said:
    @paulo@westeros:~/opt/qt5$ cd qtmultimedia
    paulo@westeros:~/opt/qt5/qtimageformats$ /usr/local/qt5pi/bin/qmake .
    paulo@westeros:~/opt/qt5/qtimageformats$ make -j4
    paulo@westeros:~/opt/qt5/qtimageformats$ sudo make install@

    The process ended without (visible) errors but when I run the application on the Raspberry I got the "defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer" - Error. Turns out that the gstreamer plugin is missing in the "plugins" folder.

    As i reviewed the config.log I saw the following lines:
    @executing config test gstreamer

    • cd /home/borsti/opt/qt5/qtmultimedia/config.tests/gstreamer && /usr/local/qt5pi/bin/qmake "CONFIG -= qt debug_and_release app_bundle lib_bundle" /home/borsti/opt/qt5/qtmultimed$
      Project ERROR: gstreamer-0.10 development package not found
      test gstreamer FAILED@

    This was correct, the package indeed was not installed. I now installed the missing package and recompiled QTMultimedia, but the gstreamer-plugin is not there, and the config tests did not seem to be executed again (edit time of the config.log did not change).

    How can i rerun the config tests? "make clean" did not solve the issue.

    Thank you in advance!

    Greetings
    Sebastian



  • Ok, turns out that this is not what I wanted after all. I am going to install QT5 natively on Raspberry as described in "this tutorial":http://qt-project.org/wiki/Native_Build_of_Qt5_on_a_Raspberry_Pi


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.