Where does QT pull Audio Device info from in Windows



  • I ask because I am only having an issue with QT coded apps and the examples in QT Creator

    It is not displaying any devices for input devices but is displaying output devices perfectly fine.

    My test apps are for QT WSJT-X, Examples in QT Creator Audio Devices Example, Audio input Example, Audio Output Example, Audio Recorder Example.

    Non-QT apps that show all devices perfectly fine including input devices: Ventrilo, TeamSpeak, Skype, Echolink, FLDigi, EasyPal, DM780 (Ham Radio Deluxe), Dire Wolf Sound modem, UZ7HO Sound modem, Winmor, (Winlink RMS Express), Open Broadcaster Software, World of Warcraft (Yes I still Play it.), and Planet Side 2.

    It is a possibility that my registry is corrupt where you look for device info which is why I am asking.

    I will link screen shots after memorial day.

    OS Windows 7 x64 Ultimate
    CPU AMD Phenom x4 9750B
    MEM 6 Gigs of DDR2 1066
    Sound devices:
    On board Realtek ALC 888 - Everything Else that isn't Ham Radio or Gaming
    Tigertronics USB SignaLink - For Ham Radio
    Roccat Kave XTD 5.1 Digital (USB) - For Gaming
    Creative Labs Soundblaster XF-i Fatal1ty Championship edition - Pull because I thought it was interfering with QT coded Apps.

    73 N1AMD Mike


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You should also add which version of Qt you are using.

    On a side note, it's Qt, QT stands for Apple QuickTime which you might also be using since it's multimedia related



  • Thanks QT 5.2.1 and QT 5.3 Both had same results.

    73 N1AMD Mike


  • Lifetime Qt Champion

    Did you test both multimedia backends ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.