[SOLVED].exe throws Syntax Error Unexpected in Qnx



  • I am trying to run a simple Example on my target board running QNX RTOS.

    My Development Environment
    Qnx SDP 6.6
    Ubuntu 12.0.4
    Qt Creator 3.1
    Qt 5.1 version
    iMx6 Sabre Auto/AI Target Board

    I was able to cross compile my Qt Application by setting the device toolkit, Compiler and Debugger. I have not connected the device with Qt Creator using SSH connection. I tried to Create a Tarball (.tar) by modiying the Run settings in Projects Tab.

    I am running QNX in VMWare Player.
    I used Momentics IDE to connect to the VMWare Player.
    I placed the hello.tar in the QNX File System
    I used the "Terminal" program in QNX to untar hello.tar
    When I run the .exe file from the terminal it shows
    @
    "./hello[1]: syntax error : <some special characters> unexpected"
    @
    Need Clarification
    I want to place the Qt Application in the SD card and run the application from the Target Board. Where am I going wrong.



  • What does command "file" says?
    @
    file ./hello
    @



  • Hi Andrec,

    When I execute the above command I get the following output

    "./hello: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamical
    ses shared libs), 0 bytes lazy stack, 4096 bytes preallocated stack,
    bytes lazy stack, -413921280 bytes preallocated stack, not stripped"



  • Looks like shell treats your binary file like a shell script
    What does 'uname -a' returns and how do you start your file ?



  • The reason for that error is that Qt related libraries are not present in the target board where QNX is running.

    I am trying to download the QNX Development Frameworf (QDF) for Qt which could be found "here":http://community.qnx.com/sf/frs/do/viewRelease/projects.qt/frs.binpkg.qt_5_2_0_development_environment.

    Thanks for the reply andreyc.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.