[SOLVED]Undefined Reference to libQtGui



  • I am tring to build a Example Hello World program for QNX.

    I have configured the Qt Version, Compiler, Debugger for QNX

    When I try to build the Application it throws 28 Errors

    Ex:
    /home/labuser/QtCommercialSDK/Embedded/QNX/485/armv7/lib/libQtGui.so:-1: error: undefined reference to `gf_draw_blit2'

    I know it is a kind of linking Error, Tried to add the following Environment Variable in Project Tab

    1. LD_LIBRARY_PATH=/home/labuser/QtCommercialSDK/Embedded/QNX/485/armv7/lib:$LD_LIBRARY_PATH

    2. QML_IMPORT_PATH= /home/labuser/QtCommercialSDK/Embedded/QNX/485/armv7/imports:$QML_IMPORT_PATH

    3. QT_PLUGIN_PATH=/home/labuser/QtCommercialSDK/Embedded/QNX/485/armv7/plugins:$QT_PLUGIN_PATH

    4. QT_QPA_FONTDIR=/home/labuser/QtCommercialSDK/Embedded/QNX/485/armv7/lib/fonts:$QT_QPA_FONTDIR

    FYI
    Host - Ubuntu 12.0.4
    QNX - SDP 6.6



  • You can temporarily solve the problem by by adding

    LIBS += -L<path to missing lib>

    but in the long term your qmake should know all the paths.
    I think such paths are specified in platform.spec, you can see which spec qmake is using by looking at the generated Makefile. It will be at the top in comments section



  • I checked in /opt/qnx660/host and /opt/qnx660/target for libgf.so.1 library file but could not find it.

    It required Advanced Graphics patch from QNX. So I downloaded them, installed the patches and built it. Now I could get an .exe file



  • [[blank-post-content-placeholder]]


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.