[SOLVED] fatal error



  • @Starting remote process.
    W/dalvikvm( 1152): PR_CAPBSET_DROP 0 failed: Invalid argument. Please make sure your kernel is compiled with file capabilities support enabled.
    W/dalvikvm( 1152): PR_CAPBSET_DROP 1 failed: Invalid argument. Please make sure your kernel is compiled with file capabilities support enabled.
    .
    .
    .
    W/dalvikvm( 1152): PR_CAPBSET_DROP 33 failed: Invalid argument. Please make sure your kernel is compiled with file capabilities support enabled.

    D/dalvikvm( 1152): Not late-enabling CheckJNI (already on)
    D/dalvikvm( 1152): GC_FOR_ALLOC freed 70K, 7% free 2552K/2740K, paused 162ms, total 163ms
    I/dalvikvm-heap( 1152): Grow heap (frag case) to 4.069MB for 1536016-byte allocation
    D/dalvikvm( 1152): GC_FOR_ALLOC freed <1K, 5% free 4051K/4244K, paused 40ms, total 41ms
    D/dalvikvm( 1152): GC_CONCURRENT freed <1K, 5% free 4051K/4244K, paused 4ms+2ms, total 49ms
    D/dalvikvm( 1152): GC_FOR_ALLOC freed <1K, 5% free 4051K/4244K, paused 19ms, total 19ms
    I/dalvikvm-heap( 1152): Grow heap (frag case) to 7.364MB for 3456016-byte allocation
    D/dalvikvm( 1152): GC_CONCURRENT freed 0K, 3% free 7426K/7620K, paused 5ms+13ms, total 49ms
    W/System.err( 1152): java.lang.ClassNotFoundException: Didn't find class "org.kde.necessitas.industrius.QtActivityDelegate" on path: DexPathList[[],nativeLibraryDirectories=[/system/lib]]
    W/System.err( 1152): at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:53)
    W/System.err( 1152): at java.lang.ClassLoader.loadClass(ClassLoader.java:501)
    W/System.err( 1152): at java.lang.ClassLoader.loadClass(ClassLoader.java:461)
    W/System.err( 1152): at org.kde.necessitas.origo.QtActivity.loadApplication(QtActivity.java:174)
    W/System.err( 1152): at org.kde.necessitas.origo.QtActivity.startApp(QtActivity.java:358)
    W/System.err( 1152): at org.kde.necessitas.origo.QtActivity.onCreate(QtActivity.java:565)
    W/System.err( 1152): at android.app.Activity.performCreate(Activity.java:5133)
    W/System.err( 1152): at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1087)
    W/System.err( 1152): at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2175)
    W/System.err( 1152): at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2261)
    W/System.err( 1152): at android.app.ActivityThread.access$600(ActivityThread.java:141)
    W/System.err( 1152): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1256)
    W/System.err( 1152): at android.os.Handler.dispatchMessage(Handler.java:99)
    W/System.err( 1152): at android.os.Looper.loop(Looper.java:137)
    W/System.err( 1152): at android.app.ActivityThread.main(ActivityThread.java:5103)
    W/System.err( 1152): at java.lang.reflect.Method.invokeNative(Native Method)
    W/System.err( 1152): at java.lang.reflect.Method.invoke(Method.java:525)
    W/System.err( 1152): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
    W/System.err( 1152): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
    W/System.err( 1152): at dalvik.system.NativeStart.main(Native Method)
    D/gralloc_goldfish( 1152): Emulator without GPU emulation detected.@

    @Your application encountered a fatal error and cannot continue.@

    Not really sure where to go from here...



  • Did you include the Qt libraries in the deployment or do you use Ministro?
    It seems that the Qt Libraries are missing.



  • I use Ministro but I have the settings set to "Deploy local Qt libraries to temporary directory".



  • So that's your problem cause. If you want to load the libraries via Ministro you have to confugre the application to do that.

    Or if the application is configured to load them from a directory, then you have to fill that directory first. I never tried that option, because Ministro works fine. Since Qt 5.2.1, the application downloads Ministro automatically from Google Play, if not already installed.



  • Since I should already have Ministro downloaded from the Qt 5.2.1 install all I have to do is point the Qt 4.8 kit at the Ministro APK? I'll try that and see where it gets me.

    The question now is, Where do I find the Ministro APK if i should already have it via Qt 5.2.1?



  • Solved for the most part. Once you have the APK, you must install it on the virtual device. If anyone wants to read more on Ministro the following thread explains a lot.

    http://qt-project.org/forums/viewthread/42010/P15/


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.