Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[SOLVED] Qt 5.2 - quick1?



  • I keep getting this error:

    Project ERROR: Unknown module(s) in QT: quick1

    I found where in the code it is referenced but don't fully understand what is going on here. Can anyone explain?

    @equals(QT_MAJOR_VERSION, 5) {
    QT += quick1
    } else {
    QT += declarative
    }@

    I tried just changing it to quick2 but that gives same error.
    I'm using QT Creator 5.2



  • Hi

    it's "quick" -> without number

    @
    equals(QT_MAJOR_VERSION, 5) {
    QT += quick
    } else {
    QT += declarative
    }
    @



  • Awesome, that solved the problem! Thanks!
    I wonder how the number got put in there and why it was there.

    Now I have a new problem:

    C:\Users\Darrel\Desktop\smartphonebrainscanner2-HelloWorld\main.cpp:1: error: QApplication: No such file or directory
    #include <QApplication>
    ^

    Is this file not apart of Qt creator? And should I make new post about this problem?



  • You have 3 Application Types:

    • QCoreApplication -> Command-Line App -> (needs module "core")
    • QGuiApplication -> Quick App -> (needs module "gui")
    • QApplication -> Widget App -> (needs module "widget")

    You are using quick, so you may change QApplication to

    @
    #include <QtGui/QGuiApplication>

    int main(int argc, char *argv[])
    {
    QGuiApplication app(argc, argv);

    ...
    
    return app.exec();
    

    }
    @



  • bq. And should I make new post about this problem?

    Yes, and please add a descriptive title to it. It will help your posts get more attention.

    @steven: goe bezig!



  • Perfect! Thanks for the info guys! :)



  • Thanks Eddy! :)


Log in to reply