-no-sse4: invalid command-line switch



  • I was trying to perform an out-of-tree build and this flag doesn't work

    @../qt-everywhere-opensource-src-5.2.1/configure -prefix /tmp/cache/bin -no-avx -no-sse4

    • cd qtbase
    • /tmp/cache/qt-everywhere-opensource-src-5.2.1/qtbase/configure -top-level -prefix /tmp/cache/bin -no-avx -no-sse4
      -no-sse4: invalid command-line switch@

    Is this a bug about the configure script ?


  • Lifetime Qt Champion

    Hi,

    AFAIK no, it's not a bug, check the output of configure --help. You should see all the possible switches and maybe sse4.1 and sse4.2 that you can disable.

    Hope it helps



  • [quote author="SGaist" date="1398115729"]Hi,

    AFAIK no, it's not a bug, check the output of configure --help. You should see all the possible switches and maybe sse4.1 and sse4.2 that you can disable.

    Hope it helps[/quote]

    the autocomplete feature in bash shows me that this flag is a valid option, maybe this problem is about how the configure script is written ? also it suggest to use just 1 dash and not the usual double dash -- .

    Try to do

    @../qt-everywhere-opensource-src-5.2.1/configure -[TAB][TAB]@

    and you will see for yourself, it clearly shows some weird options, I don't know if qt is used to do this, but for example prefix is usually composed of --prefix=<path> and not -prefix[WHITESPACE]<path>


  • Lifetime Qt Champion

    I'd say that with a script like configure, using auto-complete is not the best idea, the script is really non trivial and is used both for OS X and Linux so you might not get the options correctly.

    Trust --help, you'll have what is available for your OS


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.