[solved] unable to install Qt 5.2.1 besides Xcode 5.1 on Mac OSX 10.9.2. error: command install_name_tool failed.



  • i get the error below when running the installer. anyone understand the problem?


    Error during installation process (qt.521.clang_64.essentials):
    Command install_name_tool failed.
    Arguments: -change /work/build/PADDING/lib/QtQuick.framework/Versions/5/QtQuick /Users/stijn/Qt5.2.1/5.2.1/clang_64/lib/QtQuick.framework/Versions/5/QtQuick -change /work/build/PADDING/lib/QtQml.framework/Versions/5/QtQml /Users/stijn/Qt5.2.1/5.2.1/clang_64/lib/QtQml.framework/Versions/5/QtQml -change /work/build/PADDING/lib/QtNetwork.framework/Versions/5/QtNetwork /Users/stijn/Qt5.2.1/5.2.1/clang_64/lib/QtNetwork.framework/Versions/5/QtNetwork -change /work/build/PADDING/lib/QtCore.framework/Versions/5/QtCore /Users/stijn/Qt5.2.1/5.2.1/clang_64/lib/QtCore.framework/Versions/5/QtCore -change /work/build/PADDING/lib/QtGui.framework/Versions/5/QtGui /Users/stijn/Qt5.2.1/5.2.1/clang_64/lib/QtGui.framework/Versions/5/QtGui -change /work/build/PADDING/lib/QtWebKit.framework/Versions/5/QtWebKit /Users/stijn/Qt5.2.1/5.2.1/clang_64/lib/QtWebKit.framework/Versions/5/QtWebKit -change /work/build/PADDING/lib/QtPositioning.framework/Versions/5/QtPositioning /Users/stijn/Qt5.2.1/5.2.1/clang_64/lib/QtPositioning.framework/Versions/5/QtPositioning /Users/stijn/Qt5.2.1/5.2.1/clang_64/qml/QtWebKit/experimental/libqmlwebkitexperimentalplugin.dylib
    Output:



  • First guess: maybe you have not installed Xcode's command line tools?
    To check: launch a Terminal and type install_name_tool
    If you get "Usage:..." then it's something else...



  • thanks for your reply

    I get: "Usage: install_name_tool [-change old new] ... [-id name] input"
    so its something else



  • Hmmm, can you start QtCreator anyway (in spite of the installer errors)?



  • yes, i can ignore the errors (twice) and start Qt creator after finishing the installation.

    don't know if ignoring the errors will result in problems later, but so far so good.



  • Have you tried compiling and running a Qt program? Those installers errors typically messes up the ability for QtCreator to launch/debug your program.



  • double clicked on a .pro file, this is the result:

    Error while parsing file /Users/stijn/Desktop/Life/Life.pro. Giving up.
    Could not find qmake configuration file default.
    Cannot read /work/build/PADDING/mkspecs/macx-clang/qmake.conf: No such file or directory
    Could not read qmake configuration file /work/build/PADDING/mkspecs/macx-clang/qmake.conf.
    Could not find qmake configuration file macx-clang.
    Error while parsing file /Users/stijn/Desktop/Life/Life.pro. Giving up.



  • Ouch. While it's possible to do all the needed install_name_tool fiddlings by hand, it looks like you need to have a successful install. Maybe try the 5.3 beta instead? (there's a link on the download page just before the 4.8 downloads)


  • Lifetime Qt Champion

    Hi,

    IIRC, re-starting Xcode once the command line tools are installed and before installing the Qt package might help



  • thanks for replying

    correct me if i am wrong, but i have read that Xcode Command Line Tools are included with Xcode 5.0.x on Mavericks, so i don't need to install them.


  • Lifetime Qt Champion

    Before you had to install them by hand, with the latest version of Xcode you can download/install them directly from Xcode. But AFAIK, they are not by default



  • update:

    tried to install Qt 5.2.1 on laptop of my girlfriend.

    laptop: macbook pro, latest OS X 10.9.2, Xcode 5.1, no extra effort to install command line tools.

    installer gave no errors!

    conclusion: something is wrong locally, on my computer.



  • Maybe you change computer with your girlfriend :-)



  • haha. well, i decided to reinstall all relevant software (Mavericks, Xcode) and now it works. problem solved, thanks guys.


  • Lifetime Qt Champion

    Good !

    You're welcome !

    Since you have everything working now, please update the thread title prepending [solved] so other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.