[solved] Qt writes to /dev/tty0



  • Qt opens /dev/tty0 with echo enabled. As a result keystrokes are visible on screen buffer.
    @stty -F /dev/tty0 -echo @

    Solves the problem until application restart. Is there a way to force Qt to open /dev/tty0 with echo disabled? Or to disable console output stream to screen buffer? I found this topic with similar problem: http://qt-project.org/forums/viewthread/4778 but compiling QT with -qt-kbd-tty doesn't solve the problem.
    Any suggestions?
    Qt: 4.8.1
    Embeded Linux system

    [upd]
    Even if I setup “QWS_KEYBOARD” environment to “TTY:/dev/null” – keyboard stops working but echo is still active and visible on screen.



  • Even if I setup "QWS_KEYBOARD" environment to "TTY:/dev/null" - keyboard stops working but echo is still active and visible on screen.



  • Solution: Can be done by setting environment QWS_DISPLAY to "LinuxFb:tty=/dev/null"


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.