[SOLVED] - LibX11-xcb.so.1 => not found



  • Hi
    I just installed QT5 with QTcreator using the online installer for linux and got this error.
    I looked at the many reports of this error on the forum and elsewhere but still have not found a solution.

    I did the ldd and found this

    @linux-gate.so.1 => (0x0077c000)
    libX11-xcb.so.1 => not found
    libXi.so.6 => /usr/lib/libXi.so.6 (0x006d8000)
    @

    I do not have the source nor did I compile the package. It was installed from the web. Can anyone please tell me how to solve this. I wasted a day on this already and after trying all the good advice I could find I am still no closer to using the software.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Which version of libX11-xcb do you have on your desktop ?

    Did you installed the related dev packages ?



  • Thanks for the reply. I am not sure how to tell the libX11-xcb version. Please give a hint.
    I only used the linux online installer. I did install some things as they were suggested in the various posts but I cannot say that I installed any dev packages. What should I be looking for?


  • Lifetime Qt Champion

    You distribution package manager should tell you that.

    Not knowing which distribution you are using I can't help more.



  • Ok I found the version info. It seems to be 2:1.3.2-1ubuntu3. The dev package is also installed of the same version.

    Pic of the installed files
    "snapshot":http://picpaste.com/Screenshot-12-QrLULmO4.png


  • Lifetime Qt Champion

    You need to install libx11-xcb-dev



  • That was rather silly. I did not notice the packages were not installed. I done that and get this now.

    @Failed to load core: /opt/Qt/Tools/QtCreator/lib/qtcreator/plugins/QtProject/libCore.so: Cannot load library /opt/Qt/Tools/QtCreator/lib/qtcreator/plugins/QtProject/libCore.so: (/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/Qt/Tools/QtCreator/lib/qtcreator/plugins/QtProject/../.././libQt5CLucene.so.5))
    @
    "current installed packages":http://picpaste.com/Screenshot-15-WsJi8aMl.png

    And then I did this and see that it is missing.

    @marius@marius-desktop:/opt/Qt/Tools/QtCreator/bin$ strings /usr/lib/libstdc++.so.6 | grep GLIBCXX
    GLIBCXX_3.4
    GLIBCXX_3.4.1
    GLIBCXX_3.4.2
    GLIBCXX_3.4.3
    GLIBCXX_3.4.4
    GLIBCXX_3.4.5
    GLIBCXX_3.4.6
    GLIBCXX_3.4.7
    GLIBCXX_3.4.8
    GLIBCXX_3.4.9
    GLIBCXX_3.4.10
    GLIBCXX_3.4.11
    GLIBCXX_3.4.12
    GLIBCXX_3.4.13
    GLIBCXX_FORCE_NEW
    GLIBCXX_DEBUG_MESSAGE_LENGTH
    @

    How do I get the right version?



  • Ok it took some scratching but I think I have it sorted. The synaptic package manager did not pick up on the fact that the gcc version was not the latest. So I had to do this:

    sudo apt-get install gcc-4.7-base
    sudo apt-get install libstdc++6-4.7-dev

    and then the QTcreator loaded without a problem. Now to see if I can make it work :)

    Thanks a lot for the help, it is appreciated.


  • Lifetime Qt Champion

    You're welcome !

    If Qt Creator can load then you are ready to do some work :)

    Happy coding !



  • I spoke too quick, after the upgrade, I lost most of my desktop applications. I cannot even open a terminal or chrome. What applications are open is all that I have to work with. I am busy making copies of my crucial stuff and then I will have to rebuild the machine.
    Linux is dangerous.


  • Lifetime Qt Champion

    What distribution are you on ?

    Depending on the age of it and the possibility to upgrade, you should consider building Qt yourself.



  • I have a feeling that I did something stupid along the way and that I might have had something else missing or not installed correctly.
    I rebuild the machine on Ubuntu 10.04 (used for Linuxcnc development) and did it this way. All is working now.

    @1: Download the linux 32-bit package from the QT-project website (http://qt-project.org/downloads).
    NOTE: Do not use the online installer (nothing to fallback on)
    2: With synaptic package manager install libx11-dev
    3: then do this
    sudo add-apt-repository ppa:ubuntu-toolchain-r/test
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get dist-upgrade
    4: Make the downloaded QT file executable
    5: run qt-opensource-linux-x86-5.2.1.run@


  • Lifetime Qt Champion

    My guess: dist-upgrade :)

    Out of curiosity, can you check the Ubuntu version you have now ?



  • dist-upgrade only effected the four library files. This is the system as is now. Same as before I think.

    @Linux cnc-dev 2.6.32-122-rtai #rtai SMP Tue Jul 27 12:44:07 CDT 2010 i686 GNU/Linux
    @

    @No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 10.04.4 LTS
    Release: 10.04
    Codename: lucid
    @

    I think what happened is when I did the gcc upgrade I saw many removes. I do not know how I did it though and it was to late to stop. I guess I did not read the prompts well enough.


  • Lifetime Qt Champion

    Package management is like a contract always read all the content ;)

    What matters is that you have your documents and that you are up and running with Qt :)

    Happy coding !


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.