[solved] Using Qt MSVC 2013 64 bit machine



  • Hi:

    I am trying to use the Qt5.2.1 and the qt-vs-addin-opensource-1.2.3-alpha in a windows 8 64 bit machine. I have open the example.pro in Visual Studio 2013. When I try to run the application I get the following linking error:

    Error 6 error LNK1112: module machine type 'x64' conflicts with target machine type 'X86' C:\Qt\Qt5.2.1\5.2.1\msvc2012_64_opengl\examples\widgets\itemviews\addressbook\Qt5Widgetsd.lib(Qt5Widgetsd.dll) addressbook

    any idea how I can solve this.

    Also I would like to buy Qt Entreprise and I would like to know how to get the prices. I have write several times to Qt but don't get any response about that.

    Best
    Ernesto


  • Lifetime Qt Champion

    Hi,

    IIRC, this is generally a project configuration problem. Check that you are not currently building a 32bit application with visual studio.



  • Hi:

    Thanks a lot but now I get the following errors:

    Error 6 error LNK2038: mismatch detected for '_MSC_VER': value '1700' doesn't match value '1800' in adddialog.obj C:\Qt\Qt5.2.1\5.2.1\msvc2012_64_opengl\examples\widgets\itemviews\addressbook\qtmaind.lib(qtmain_win.obj) addressbook
    Error 7 error LNK1319: 1 mismatches detected C:\Qt\Qt5.2.1\5.2.1\msvc2012_64_opengl\examples\x64\Debug\addressbook.exe 1 1 addressbook

    this is really annoying since this is just the Qt examples

    Thanks for your help


  • Moderators

    Because you're using Qt built for VS2012 in VS2013 ;) That's no good. Both - compiler and runtime libs have changed between these.

    There are no official builds for 2013 but you can either build it yourself or use "these":http://www.tver-soft.org/qt64



  • Thanks for your help I did not saw that sorry


  • Lifetime Qt Champion

    Misssed that one too...

    If you want you can also grab the latest 5.3 beta which has a package for VS2013



  • Thanks very much for the help


  • Lifetime Qt Champion

    You're welcome !

    Don't forget to update the thread title prepending [solved] if you have it working now so other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.